Xiaomi button pairing issue WXKG01LM

Tags: #<Tag:0x00007f325d2dc968> #<Tag:0x00007f325d2dc878> #<Tag:0x00007f325d2dc710>

Hi everyone,

I’ve been trying to pair Xiaomi Buttons (WXKG01LM) via Phoscon WebApp (I’m using a Conbee II usb stick with Deconz integration) for hours now and it drive me nuts …

I get one of these button successfully paired a few weeks ago, pretty easily.
Now I’m trying to add 3 buttons freshly out of the box and there is no way I get any of them paired…

I follow to pairing process as explained on several topics :
press reset button for +/- 3s.
press reset button shortly every 3s

I’ve tried to press reset button for 5s, and almost everything that came through my mind but I’m still facing the “Failed to connect” error after the 3 minutes scan on the Phoscon WebApp.

Any help would be greatly appreciated !
Best,

After pressing the reset button (according to the deCONZ docs, for about 5 seconds), does the LED start blinking? Have you tried replacing its batteries?

Hi @robertklep

Thanks for your reactivity.

the LED sometimes blinks 3 times (like the instruction said) and sometime blinks very fast until I release the reset button.
I don’t know what does the fast blinking mean…

I tried several out of the box batteries.
The paired button works at this location (about 3 meters near the Conbee Stick) so I guess the range is not an issue.

OK I finally got them paired after moving the stick to another USB port. Can’t tell what was wrong in the previous port since the paired buttons was working like a charm on it.

Still, for those who came here with same issue. Make sure your stick is plugged in a USB 2.0 port (seems it don’t like USB 3.0) and double check the path to your conbee stick (it’s not always ttyACM0)

Thank you @robertklep for trying to help !

Best regards