Xiaomi cleargrass Bluetooth gateway

I have a bluetooth gateway “ClearGrass CGSPR1 - Qingping Bluetooth Gateway” and I can’t reconnect it to my home network (I’m using a router: Compal Connect Box from UPC). When I first connected to my home network via the “Mi Home” application, everything worked fine and the gate was added without any problems. However, after a while in the “Mi Home” application it was inactive (gray). I decided to remove it from the “Mi Home” application and add it again. When I try to add again, only the first two steps are performed correctly, but the last point “Connecting device to network …” shows an error. I have tried several times and I get the same error every time. I tried to add this gateway by connecting my phone to a HotSpot made on another phone and it worked. However, trying to connect again while I was connected to my home Wi-Fi network resulted in the same error every time. On my router I only set up the 2.4GHz Wi-Fi network, turned off the firewall, changed the network name and password to simple but that did not solve the problem. I returned to the original configuration of the router, where the gateway connected only the first time. Can You help me ?

I changed the Wi-Fi settings encryption from “mixed WPA-PSK/WPA2-PSK” to “WPA2-PSK only” in my router and it worked. Thank you @rezmus89 from reddit.

Do you know how to connect CGSPR1 to HA? Apparently it has an ESP32 module in it. But how to connect it with HA?

I dont know, never tried it.
I even bought the damn device but plain esp32 with espHome is too good to even bother trying :slight_smile:

As it comes, I don’t think you can. I took mine apart (destroying it in the process) and indeed it is a power supply and an esp32 in there. You’d effectively need to destroy it to reach the programming pins.

With a little more care you could probably take it apart and replace the case with something 3D printed.

Why do this? Well it would be a great at communicating with ble devices using esphome. Nice case, compact, built in power supply, standard esp32 chip. But unless someone can find an OTA flashing method, it is physically tricky.

I think what we all really need is a nice mass-produced case for ESP32 boards that is not 3D printed…like the Flirc case for the Raspberry Pis, just something we can throw 5-10 bucks at and declare the problem solved in a beautiful way. Their Pi Zero case looks stunning, not sure how it affects Bluetooth/WiFi range considering all the aluminum, but I would really love something like that.

Also an ESP32 with a LAN port that doesn’t cost a ton of money, but that’s another story :slight_smile:

I think Xiaomi is really heading in a direction of closing access to all their non-Zigbee stuff, which is a shame…

It is the inclusion of the power supply and esp32 in one simple little wall wart that I think is good.

And tuya is starting to put non esp8266 chips in their devices. GRRRRRRR

1 Like

WHat we need to do in the absence of someone injection moulding a case is to find a donor device that is easy to open and has a good WAF.

Something that can be opened with screws (i am thinking like the Kogan smart plugs) - strip out the inside and put in a USB to mains adapter and ESP32.

I am going to scout around our place and see what i have lying around


1 Like

Case and power 12V gateway - http://lock.3dn.ru/news/dorabotka_shljuza_xiaomi_cgspr1_bluetooth_wi_fi_gateway/2020-08-23-192

I was able to connect HA to a CG gateway using the Xiaomi Miio integration. I retrieved the token using bluestacks. No entities have been autodiscovered. Unfortunately, I only have miflora plant sensors and these are not yet in the X Miio integration, so I don’t know whether the autodiscovery works or not.


Also connected Cleargrass BLE gateway CGSPR1 through Xiaomi Miio integration, no new devices were added. In MiHome he sees all my 8 temperature and humidity sensors LYWSD03MMC and Cleargrass CGD1 alarm clock without any problems. It would be convenient to integrate it into HA. :slight_smile:


How did you manage to connect the gateway in more detail?

How did you connect the gateway to the HA?

Through integration, but it does nothing.

The integration adds support for another gateway. As a result, your gateway cgllc.gateway.s1 is not defined in the HA and therefore cannot work.
Of course, I found that BT sensors can be connected via a BT dongle( sensor.mitemp_bt ), but this solution seems to me not the best. Judging by how the dongle is loaded.

Yes, integration simply adds an entity that does nothing (perhaps for now). I added it just in case something changes, I will see new entities.

I did, all my sensors work perfectly.

I have already tried different methods. This gateway cannot be integrated into Home Assistant.

Forgive me for the delay in answering. I have not kept trying to unmount the device. In the end it has been easier and cheaper for me to put a mini esp32 inside my clock radio with the configuration of all the temperature sensors in the rooms. The invention is not visible :wink: but it is effective.

1 Like

What does it mean, would you give me detailed description about how I can do it too?

"put a mini esp32 inside my clock radio with the configuration of all the temperature sensors in the rooms"

thank you.

esphome would be the easiest way.