Xiaomi Floracare reliability

Hi everyone,

Does anyone has reliability problem with the Xiaomi Floracare sensor ?

I have a batch of 3 that stopped working, one after the other, a few days appart.

I’ve tried to replace the batteries with known good ones (tested the voltage, received 3v ± 10%).

I can’t see the bluetooth devices sending packets, when I replace the batteries the led doesn’t seems to blink (hard to see).

I’ve purchased those 3 from the same vendor, just wondering if I would have received a bad batch.

Does anyone experienced the same thing ?

Any idea how to fix this ?

Thanks !


what are you using to connect to it? ble via your host?

I know that there have been some errors in the native component of late.

I have loads of them. A couple have failed in the past, but generally they are quite reliable.

i have a bunch - they failed at similar times, as the battery died. Work with new batteries.

Have you checked with the miflora app? or just you HA integration?

Hey uiguy and Jon,

I don’t see them active when scanning with a laptop, with the hcitool lescan command.

Additionally, my Wifi AP is scanning bluetooth devices and is reporting me when devices are disappearing and when they are showing up gain, this is how I’m detecting when a device is gone.

To answer to your questions, I’m using a RPI 3 running hassio to extract the data.
My first one works as usual, firmware is different though.

I will try to buy new batteries and swap them to see if it would change something, but



Hi, there is a big difference between resinos and hassos on RPI… i could not get BLE to work on resinos… or hassos… can’t remember…

I now use plantgateway to get the data from the devices (via multiple RPI’s) into my main instance of Hassio (on Intel NUC)

as do i. with no issues.

Hey guys, the thing is the units are not communicating at all.

I have another sensor that I bought a while before that batch of 3 that is still working. I can see it broadcasting messages.

I have tried to communicate with them from the Xiaomi app with my iPhone, less than 1 foot away, it is not working either.

I’m wondering if the units aren’t just dead. When I remove the batteries and replacing it in the compartment, the led doens’t even blink. I have metered the batteries, they are good (3v).

I’ve tried to contact the vendor on Aliexpress to see if there is any way to get them RMA. We will see.

Thanks for your help !

BTW, I will implement plantgateway so I could move my hassio to a more powerfull unit (the pi is a bit slow).


Interesting, I have swapped the batteries 20 min ago, the sensors are back online.

This is puzzling me, I have tested the voltage from them and they were looking good.

Regarding the brand, those were coming from Dollar store (Sunbeam), I have swapped them for Energizer. We will see how it goes.

Thanks !


Yea, I noticed that duracell batteries drained super fast… I use now GP ones which seem to be working really well…

The other thing to remember when using the flowercare app is that some devices are for use in china mainland only and others are international version… This distinction does not impact at all BLE comms with things like HA or plantgateway as you are still able to retrieve the data… but bottom line is that I don’t really always trust the defaul miflora apps, rather make sure you have a good BLE sniffer…

Otherwise, glad you got them working…