Xiaomi gateway isn't updating status

the problem is that my gateway shows only that info (light and illumination) that was at hass start moment. After that it never updates. When I try to turn on light i click radio button and it actually turning on the light but after that switch moving to ‘off’ state and not reacting anymore. Lan control is enabled, key obtained and correct. Here is my config:
- key: ztlcrwntv58sut2y

The behavior is very similar to this: Xiaomi gateway issue

but i have everything in single subnet and there is no error messages about invalid keys. With xiaomi_gateway: debug I see following when enabling light:

2019-01-24 19:34:36 DEBUG (SyncWorker_15) [xiaomi_gateway] _send_cmd >> b’{“cmd”: “write”, “sid”: “4cf8c743be0”, “data”: {“rgb”: 1694498815, “key”: “baf34bf97af0b747736cda2c98d9f041”}}’
2019-01-24 19:34:36 DEBUG (SyncWorker_15) [xiaomi_gateway] _send_cmd resp << {‘cmd’: ‘write_ack’, ‘model’: ‘gateway’, ‘sid’: ‘4cf8c743be0’, ‘short_id’: 0, ‘data’: ‘{“rgb”:1694498815,“illumination”:382,“proto_version”:“1.1.2”}’}
2019-01-24 19:34:36 DEBUG (SyncWorker_15) [xiaomi_gateway] write_ack << {‘cmd’: ‘write_ack’, ‘model’: ‘gateway’, ‘sid’: ‘4cf8c743be0’, ‘short_id’: 0, ‘data’: ‘{“rgb”:1694498815,“illumination”:382,“proto_version”:“1.1.2”}’}

Any ideas?

Did you try using MAC instead of HOST? And discovery retry to 5?

  discovery_retry: 5 
    - mac: a1b2c3d4c3d2
      key: ztlcrwntv58sut2y

replace a1b2c3d4c3d2 with the mac address of your gateway. And restart HA.

Just tried, same result…

I still can’t solve this problem… Is it possible that reason is that I use Windows OS for Home Assistant?

Hi Ivan,

I have exactly the same problem with one of my gateways.
I’m using two gateways (both of them are lumi-gateway-v3) configurated in the same way but one of them has the same issue like you described. Did you manged to solve this problem?

Unfortunately no solution so far. But i found a ticket on official issues tracker, please describe your situation there and maybe dev team will fix this faster: https://github.com/home-assistant/home-assistant/issues/20329

OK, I just added few comments about my issue.