Xiaomi Gateway sensors not working

Hey Guys,

yesterday, my first Xiaomi Gateway (v3) arrived.
I made a few firmware updates (SW: 1.4.1_151.0143), turned on local connections and put the gateway into my HA.
I tried to turn on the light of the gateway or get sensor data from illumination sensor, but nothing worked.
But, I can play ringtones from my HA Webinterface so, connection is working well.

Here is my config:

    - host:
      mac: 7811dcb06004
      key: 30ulttcxxxxxxxx

And here is my log error:

(SyncWorker_1) [xiaomi_gateway] Non matching response. Expecting read_ack, but got get_id_list_ack

Hope, someone could help me.

Thanks !

EDIT: Router supports multicast and it’s enabled. All firewalls (iptables, ufw) are off.
EDIT2: Automatic discovery of my gateway isn’t possible. Only runs with host:

Not sure, but here’s another config example. Perhaps the host, and mac entries are throwing it off.

  discovery_retry: 5
    - key: 30ulttcxxxxxxxx

Also activating the


option in your configuration.yaml will automatically discover them, another possible test.

Wow, fast answer, thanks ! I will give it a try.

UPDATE: Tested and not working. HA is discovering my gateway but same error in my log.
[xiaomi_gateway] Non matching response. Expecting read_ack, but got get_id_list_ack

Any idea ?

Hmm, you’ll need a wiser head than mine. I’ve not seen that error.

Bound to be someone along, or some other similar posts in the forum.

I have found a few people with this error, but no solution is working for me…
But thanks, anyway.

I got it working! Big thanks to @syssi.
VM ware was my problem.
Installed it on an RPI3 and Hyper-V virtualisation with Debian and both runs great.

Please close this thread.