Xiaomi Gateway setup HA 0.112

Tags: #<Tag:0x00007f7390c4d0c8> #<Tag:0x00007f7390c4c538> #<Tag:0x00007f7390c4c420>

I have some some Xiaomi Gateways (Aqara) in my setup
Most of them located in the different routed subnets. So the discovery is not working for them.
In the past setup I have the host directive to point the HA to the exact GW
Now it’s deprecated
And I couldn’t find any way to set the IP address of GW via HA GUI
Is there any chance to point the IP addresses of GW in new HA?

3 Likes

Same problem here. Hope that there is a solution soon.

I have the same issue after update, all of my gateways sensors are showing as unavailable. Even though I have the IP addresses correct in the configuration yaml file. Also auto discovery is picking up the gateways (homekit?) and I did configure them to try to get my sensors that way but:
a) it only picks up lumi gateway v3 and not the AC companion gateway, and
b) it doesn’t pick up the door and motion sensors, only allows to arm/disarm gateway

Any news on this? My gateway appears in the integrations tab but asks to enter a network interface. I have tried everything and it fails. Default option is “any”; using the IP from the HASS device doesn’t work either.

I’ve tried disabling and enabling again the LAN mode of the gateway with no efect. Curiously, the Xiaomi Miio integration does allow adding it, but it is of no use since it does not give access to the functionality of the gateway.

1
2
3

1 Like

Same problem for me after HA 0.112. I’ve places gateways and HA in the same vlan. All my sensors are not available. Please fix this integration.

I have the same issue, once upgrading to 0.112 all my Aqara sensors became unavailable.
I’ve added the Gateway as an integration now and the sensors show up, but it’s going to take ages figure out which sensor is which now that it has renamed them all.

Ok the trick is to delete the gateways from the Yaml and add them as integration. I didn’t see that on the release notes of v0.112 but that’s my fault.

1 Like

It works only for gateway that are discovered
If you have a GW in the different networks - there is no way to add it via integration :frowning:

1 Like

That’s a good point. At the moment I’ve the gateways in the same VLAN so they are discovered by HA. After that I changed the VLAN of my IoT network, so the gateways got a new IP. The current integration is broken after that. And the gateways are not discoverable. I can also not change the IP at the current integration.

I had the same problem.

Adding the gateway via integration solved it for me too. It didn’t show up, so I had to add (+) it manually. I chose the Xiaomi Gateway (Aqara), not the Xiaomi Miio. I have the Xiaomi v2 gateway.

Thanks!

I just copied xiaomi_aqara folder from 0.111.4 to custom_components for now. It couldn’t get discovered (hassio is on vlan 10 while gateway is on vlan 20) through 0.112 integrations.
Before this, I am only able to use it for the sound effects (the light component occasionally drops out and I’m not using it as zigbee gateway anymore)

EDIT: looks like this is tackled at https://github.com/home-assistant/core/issues/37306

Weird. With zeroconf disabled I get this error:

A Xiaomi Aqara Gateway could not be discovered, try to use the IP of the device running HomeAssistant as an interface.

When I activate zeroconf in the configuration.yaml got this one:

The Gateway discovered by Zeroconf cannot be located to obtain all the necessary information, it tries to use the IP of the device running HomeAssistant as an interface.

Both the Gateway and Home Assistant are connected to the same network but using the Raspberry Pi IP (running HASS) as an interface does not work, it returns an error. Using the IP from the Gateway or the Router doesn’t work either. Also using “any” as an interface drops an error. Could it be the Gateway version? It is V3 but it’s strange since HASS detects it.

Hi there, I have the same issue as flipflop1.

Device info:
lumi.gateway.v3-MW300
by Xiaomi
Firmware: 1.4.1_176

I have no idea how to resolve it.
Is there some way to fix this issue?

Same issue here…

Yup I have the exact same issue here as well. Started after 112.0. When I try to use the integration it complains that the device is already setup. I’ve already removed it from configuration.yaml. In the logs it shows invalid key but it’s not. I even tried regenerating the key and still not working.

I have the same message when I use any as variable. If I type in the address 192.168…:8123 to the variable then I get the following message: invalid network interface
What do I do wrong?

Same issue here, after upgrading my two gateways (same LAN), already configured in configuration.yaml, are discovered. Before asked me for the token, I’ve put it and seems ok, also for me alarm appeared and sensors are not working. Afterwards asked me for the network interface, but with any gives me back “Zeroconf discovered Gateway could not be located to get the necessary information, try using the IP of the device running HomeAssistant as interface”

As far as I know, configurating the Gateway via the configuration.yaml is not longer supported. It only works via the integrations page. But, I’m not even been asked for the token or password of the gateway since I always get the same error saying “invalid interface”.

Seems that everyone is having the same issue (it’s already been tracked in Github) so I guess all we can do right now is wait… :sweat:

I have the same issue after update. MyCurrent version is 0.112.4

Same problem here.