Xiaomi Light Sensor Exposes in Zigbee2Mqtt but not in HA

Good day

I have a Xiaomi Light Sensor and Zigbee2Mqtt says that it is exposing the correct values. (See Screenshot 1 in attached image). I confirmed this by checking MQTT directly and the values are reported.

But in Home Assistant it only sees Lumens Lux and Battery Level. It does not see Link State or just Lumens. (See Screenshot 2 in attached image)

What I also noticed is the following. I did not add it and none of my other Zigbee devices have this setting. (See Screenshot 3 in attached image).

When I try to delete it the above, I see this error. (See Screenshot 4 in attached image)

I already deleted the device twice, restarted Zigbee2Mqtt, unplugged my coordinator, plugged it in, restarted Zigbee2Mqtt but still not working. I also restarted my Pi running Home Assistant but also not working.

My versions:
Core: core-2021.10.4
Supervisor: supervisor-2021.10.0
Home Assistant: Home Assistant OS 6.5 and Production Deployment
Zigbee2Mqtt: 1.21.2-1

I will appreciate any help. If I need to post more details please let me know then I can post the details.

Thank you

Go to Configuration / Integrations / MQTT / Your device.

In the device entities box click to show disabled entities at the bottom of the list. Click on each of the disabled entities. Enable them. Click on Update. Restart Home Assistant when finished.


(not a zigbee light sensor but you get the idea).

Thank you so much! This worked like a charm! I learned something very valuable now.

I noticed in MQTT the “Enabled by Default” tag but didn’t think much of it. I guess this had to do with the entity not being enabled out of the box.

EBD

Yes, the “enabled_by_default” was introduced some zigbee2mqtt versions ago.

Awesome stuff, thanks for confirming!