Xiaomi Miio integration: cloud needed?

Hi folks,

I had the Miio integration for my Xiaomi Airfresh running from HACS until recently. Then it got integrated in to HA, so I removed the HACS integration and used the HA one. Great.

But a couple of weeks ago the integration stopped working: I could still see my two devices, but no entities to do anything with them. I just removed the integration and let it rediscover my Airfresh: it asked for a cloud username/pass. I really cannot overstate how much I did not want to do this. So, I got to advanced and was able to add my api token (not recommended: why not?) and got the device in HA.

However: situation is still the same. I can see 1 device and 1 entity. But no controls for fan speed or favorite, etc… am I missing something?

Please don’t tell me I need to use the cloud now. This is the reason I quit using Homey and started with HA. All my IoT devices are blocked from any kind of internet access. And besides that: I do not want to use the Xiaomi cloud via HA either: I just want to run it locally. Is this still possible?

(I cannot find the HACS integration anymore, probably removed after it got added to HA…)

Is there anyone who can help me get my airfresh working again without cloud access?

Ok, just for reference: removing the integration (official) and the lines from .conf I re-installed the HACS plugin. After that I re-added the lines to the config and I now get the fan settings again. Would be nice to see this in the official integration. I really do not see any advantage in using the cloud plugin. I think HA is taking a wrong turn here.

1 Like

I am also a little confused with the Xiaomi Miio integration.
The entire point of HA for me is not use any cloud. I do not mind to use it for setting up things, but operation and all accesses after that have to be local. Is that now the case with Miio or not?

Just after 10 month of waiting, I’ll try to move the subject up a bit. I’m migrating to HA from an pure offline system, and the cloudless question interests me as well. If someone as an idea…
I added my two vacuum robots flawlessly, providing the login/pass, so without including the tokens anywhere. Controlling the robots works when online, but not -always- offline. And when it works, it has a LOT of delay.

edit after some tryouts: On the 2 robots, I re-included one with the token, not the other. when offline, the behaviour remains the same, and I see no token added anywhere in some yaml.