Xiaomi Mijia 1080P 170 ° Smart IP CAM (MJSXJ02HL)

I have tested.
No bootloader change,
no backup required.

No record on SD card … Install addon motioneye
The Internet is very busy and the router does not catch up. I’m trying to combine H265 playback instead of H264

Great. Thanks for the quick reply.

1st batches of this camera came with unlocked bootloader. if you have newer batch you have locked bootloader which only accepts signed firmware. if camera won’t accept custom firmware (demo_hlc6.bin) you have to replace uboot with unlocked one (demo_boot.bin).

Hi bishop, at the moment I can’t test it unfortunately. reading the guide I had your same doubts too and I would have liked to ask the same questions you did. as for the bootloader I had thought of following the guide for loading from microsd. so first the bootloader and then the firmware, the backup instead I thought not to do it.

Yes, I bought cameras a year ago.

Hi bishop,
did you tried the custom firmware?


I’ve tried to flash the firmware but did not have much luck so far.
I first tried flashing the firmware directly. This did not work. The LED would stay orange and not turn white as said it should and the firmware would not flash and the original firmware was booting up.
I then flashed only U-BOOT. This seemed to work. The LED turn white and then back to orange after a while.
I then flashed the firmware. Again this seemed to work, but I cannot connect to the camera. The article say that a wifi hotspot should be present, but I see nothing (I tried forcing the SSID in case it was hidden as well, but still no luck). I also tried configuring my wifi data in the conf file as explained in the article but the camera does not connect to my wifi.

I tried quite a few times now. With UBoot alone, with firmware alone, with Uboot and firmware together on the SD card … each time I have the same result. The camera seems to flash something but I cannot connect to the camera in any way :frowning:

Of course I was too lazy to do a backup of the original firmware so now I have a camera which is not working anymore. I’ll try some more but don’t have the time to continue playing with this right now. Let me know if you try and if you have more luck!

I’ve tested some more, this time with the USB method (see details in article two of the russian site). Installing the driver is a bit painfull but at least I have some feedback on what’s happening via the Hitool. I can flash the uboot fine and I can flash the custom firmware fine (Hitool confirms the flasing went fine), but then the camera still doesn’t do anything (no wifi network create …). Using Hitool and the original firmware images downloaded from the russian site, I manage to reflash the original firmware and can reconnect the camera via the Xiaomi Home app, so at leat not doing a backup of the original firmware was not such a big issue. Still I would like to have the custom firmware working so if anyone has an idea of what I’m doing wrong please let me know :slight_smile:

i see a new custom firmware version 1.2.6 (09/27/21).

It’s very strange that you did not see the wifi network. Anyway…Thank you for your feedback.

Thanks for pointing me to this new version of the firmware. I’m not sure if they changed something with this new version or if I did something different, but this time I managed to flash the camera.
It’s now working and connected to home assistant :slight_smile:

happy to read this form you.
So according to you how is the cam working with home assistant?
Is the streaming good? the motion sensor is working fine?
is it stable?

The streaming is working well and so far it seems stable (running for 1 day now without problems). I tried quickly to have the motion detection linked to MQTT sensors to have alerts on motion detection, but it did not work straight away and I did not have the time to look at it in detail. I’ll try to look at it when I get more time.
As far as I’m concerned, the hack is well worth it :slight_smile:

Hello, I have one of this cameras and I am very interested in making it work on HA. After flashing the camera with this demo_hlc6.bin, it continues working with mihome? Which is the syntax of the RSTP string to see video via RSTP? Thanks!


Once you flashed the camera it stops working with mihome.
The syntax for the RTSP and the image URL and how to integrate it in home assistant is detailed in the article explaining how to flash the camera and posted by TheBisk in this thread.

I copy it below for reference (you need of course to replace the IP addresses with your camera IP) but I’d advise you to take the info directly from the article.

  - platform: generic
    name: mjsxj02hl
    still_image_url: ""
    stream_source: "rtsp://"

Great, Thank you!

Is it possible to undo it by reflashing with the original firm?

And about the link, I searched for the configuration in the article but I didn´t notice, sorry! Now I have seen it.

You continue using the modified firm without problems, isn´t it?

If you have a backup from the original firmware, you can reflash the camera with the original firmware, but I think you need to follow the method using a USB connection described on the website (at least it is that way I’ve done it). It is a bit more difficult but I managed to do it after a few trial and errors (timing is a bit hard to get). And yes I am still using the modified firmware and so far no problem.

You mean a .“bin” form the original firm, right? It is supposed that in case the flash works,yo can put the original bin in the root of the SD an reflash again, right?

And thanks for you feedback!! It is great to know there is a way to integrate this camera in HA.

I have flashed the firm and it is working fine with home assistant. I haven´t tested mqtt yet but I think it will work too.

Hi. I did flash the camera. Now im able to connect access point named MJSXJ02HL

But i cant get into the setup…

I did use:

IP address:
Subnet mask: (24)win10
Default gateway:

What did i do wrong?

Hope you can help.