Xiaomi Mijia Smart Multi-Mode Gateway (ZNDMWG03LM) support

Tags: #<Tag:0x00007f3268e85958> #<Tag:0x00007f3268e85890>

Hello all, was anybody able to add bluetooth sensor using this method? My home assistant is able to recognise gateway and i was able to add it as homekit accessory. Due to fact that this gateway has bluetooth it’s able to act as BLE gateway and successfully discovered my temperature and monitor sensors (LYWSD03MMC) but i’m not able to add them to home assistant.

While normal sensors detects proper, has anyone tried aqara cube integration? I was not able to get it into home assistant, would assume homekit might not have cube compatibility but would love to hear from you guys.

Dear All, I would like to ask for your help. My home assistant is not able to recognise the multi mode gateway. I could not find any device under the HomeKit component. Thanks in advance for your help

Hi,
Any update on this? have you succeed to view bluetooth sensors in homeassistant ?

can the multimode gateway be blocked from the internet like the old gateway and still function?

Mini review:

I have one, but as of now I decided not to use it. At least until the software matures a bit.

Yes, it can be added to HA via the HomeKit integration. But the good news stop there.

It doesn’t expose to HomeKit a lot of things. For example water leak sensors, although Aqara, they are not exposed. I also have Aqara movement sensors, they are exposed as movement sensors, but not the illumination sensor.
Even what works, it’s unusable. The door/window sensors are reporting the status after ~5 minutes. And not only in HA, but also in the Mi Home app. The same sensors linked to the old gateway, in HA change status instantly.

Another annoying thing, the new hub only having a beeper, sometimes you don’t know why it beeps. And it does beep, out of the blue, without anything obvious happening. And there is no notification in the Mi Home app. I disconnected it after it started beeping one afternoon, every 10 minutes or so, and I could not figure out why.

As of now, the old CH region gateways in LAN mode are a better option.

3 Likes

I can confirm almost everything, except reporting to MiHome and HA. In my case I have Aqara Motion sensor, and report time to MiHome is extremely fast, but like 20-30 seconds to HA. Also battery status is unchangable at level 95% (44% in reality).

1 Like

My motion sensors are the Mijia ones, not Aqara.
And I’m on chinese mainland server. Lately those are absolutely overwhelmed, the Mi Home app is barely functioning. I also have a Xiaomi camera and there are instances when I simply cannot connect to it.
I’m hoping they are working on upgrading their infrastructure. If not, soon it will grind to a complete halt.

Hi,
I has bought one of that, but I share the previous things:

  • End to end: there is very long latency on update
  • Bluetooth things aren’t shared via HomeKit interface
  • Restrictions on usable Zigbee devices

But I found maybe a bug… :confused: my test env runs in a VM on a laptop. Sometimes I hear it’s fan, but while I enabled the HomeKit integration for this GW the HA runs one CPU core on 100%.

And I found a candy in the logs:

WARNING (MainThread) [homeassistant.components.homekit_controller.connection] HomeKit controller update skipped as previous poll still in flight

If I restart the docker container of the HASS the things work again.

So, now I think I have a fresh new GW for sale :stuck_out_tongue: :frowning:

Hi, I have HA installed in a python virtual space, I can see the new Gateway in My Home, but HA does not detect new integrations. Perhaps it may be because I have not linked any device to the Gateway, I have all of them in my old Gateway, is it possible that this is due to this?

Update: worked after restarting everything. However motion sensors are slow to report to HA.
Added to HA via HomeKit but the sensors have not been updating since. (aqara temperature sensors)

So far i’m agreeing with what you’ve said, i’ve installed the new Gateway via Mi Home (i’m in Australia) but i’m working off the China mainland server as this is the only way to integrate the Temperature Sensors I also Bought (Aqara latest versions). Homekit Integration is fairly straight forward, it actually integrates from the Mi Home App and automatically links to Homekit.

Problem with the temperature sensors is they are slow responding like you said ,maybe it’s going through the Chinese Servers back into the Gateway (that would be annoying if so). Also on the Homekit side of things, even thoguh i named the rooms the same they don’t show up in those rooms they go to “Default Room”. It’s hard tro work out which sensor is which TBH so i haven’t moved forward to change the room in Homekit.

The gateway doesn’t come up as and option like another user said it would above and I haven’t tried integrating the temp sensors in HomeAssistant yet.

I have this ZNDMWG03LM model. Was able to integrate successfully in HA and also able to detect its child device - Mi Wireless Switch.
Problem is that it cannot detect my Yeelight Smart Downlight YLSD01YLthat is using bluetooth.

Unfortunately, this gateway does’t expose the BLE devices, because these aren’t children of it in the Xiaomi terminology…

I have sensors only and I could drop the gateway by the https://github.com/custom-components/sensor.mitemp_bt project. But I don’t know what should you use…

Hi,
My Gateway (ZNDMWG03LM) with firmware version 1.4.6_0012 have the same issues.
Have you succeed to view bluetooth sensors in homeassistant ?

Does it support magic cube? I mean, does it discover magic cube in HA after connecting it through Homekit_component?

Hi, thank you for your information about switch. However, I tried listening to “Xiaomi Events” and then pressed the button, but nothing happened. Could you give more specific info related to button press event. I integrated this multi-mode gateway through Homekit. Thanks.

I believe if you have it connected through HomeKit you should be listening to HomeKit events.

Hello.
I have a strange issue.
Hub added to HA without any problems. After I restarted home assistant all sensors connected to hub appeared without any issues. The only thing i’ve seen for now, that temperature sensor not showing atmosphere pressure.
Then after few days i’ve discovered, that information from all sensors that were connected to hub not updating. And it wad not updating, until i rebooted hub. After that everything works fine again, for a few days. Actually 1-2 days - time when all sensors stuck is random. And then again, all sensors were stop updating information, and i need to reboot hub again. And again and again.
In Mi Home everything works fine, all sensors are updating information, but in HA they are stuck after a day or two of perfect working.
Reboot of HA not working, only reboot of hub helps.
Does anybody have seen such issue, how did you solved it?

Can you control this device (locally using HA) to make beeps and different sounds like that?
I am looking for something that can make sounds for alert times and doorbells etc, without using a cloud service.