Xiaomi Mijia Smart Multi-Mode Gateway (ZNDMWG03LM) support

Tags: #<Tag:0x00007f7800299008> #<Tag:0x00007f7800298f40>

I tried add xiaomi multimode gateway in home assistant over homekit, but i have error message “Device refused to add pairing as it is already pairing with another controller.” When i remove device from xiaomi mi app, device lost IP address. How add multimode GW to home assistant?
thank you

Here are some screenshots (from my mobile app).

I also would like to share some immediate experiance with the new gateway and integration in hassio. First of all, hassio did not update new devices added to the gateway after the integration to hassio was done. After integrating the new gateway to hassio (via homekit accessories integration) for the first time, I added some thermometers to the new gateway in the Mi home app. These thermometers was not discovered by hassio (tried to restart hassio but this did not help either). To add these thermometers to hassio, I had to remove the gateway from the Mi home app and re-add it. Hassio then discovered the gateway again (suggesting a new integration - homekit accesories) and after integration again, the thermometers was discovered by hassio as well.

I have successfully added the new light sensor, movement detectors and thermometers (both the sircular and square version) to hassio via the new gateway. All alongside other xiaomi devices added an older gateway.

As for the thermometers there are some peculiar findings in hassio when integrated via the new gateway. For the square versions, the air pressure does not seem to be supported in hassio, although it it supported in the xiaomi home app. And the temperature shown for the square versions are without decimal (e.g. 21 degrees and not 21,4 degrees). For the circular version, the temperature is given in hassio with decimal. The same difference applies for the humidity.

As I am a new user, I am only allowed to post one picture in each post. Here is another screenshot.

After adding the new gateway to the Mi home app, my hassio discovered a new integration (“Homekit accessory: Mi Smart Home 8332”). When I clicked on the new integration I was told to enter the homekit code as printed inside the box that the new gateway was packed in. After doing that, the gateway successfully was integrated to hassio. I do not have the homekit app (nor Homekit speakers) and uses android.

To be able to discover new devices connected to the gateway in hassio, I have removed (from the Mi home app) and reintegrated the gateway a few times. Sometimes after readding the gateway to Mi home app, hassio does not alway discover the gateway as a new integration. Sometimes I have to repeat the procedure a few times to succed (and also restart hassio). It sometimes also takes a few minutes for hassio to discover the new integration (gateway). If hassio does not automatically discover the gateway as a new integration, I am not able to add it manually by adding a new homkit accessory integration (hassio only discovers Ikea as a homekit acccesory, no Xiaomi gateway).

Do anyone have tried to connect WSDCGQ11LM through this hub and home kit. I tried it with old aquara hub, and have only humidity and temperature readings, no pressure. With gateway 2 and xiaomi_aquara integration i have all readings, humidity, temperature, pressure, battery level.

Same results with this link.From Russia too :smiley:

I have a different issue: when using integration via HomeKit all seems fine - all sensors ware found (2 temp sensors + 1 button) but the readings (temp, humidity & battery) are refreshed only when I restart HA. I use Hassio on RPi2, anyone had similar problems?

Are sensors connected/paired to new xiaomi gateway shared to old xiaomi gateway (and then to hassio)? Or i can access to then only over homekit integration?

Nope. You need to remove sensors from old gateway and repair them with new one.

I’ve added an Aqara Wireless Mini Switch to my new hub and it communicating well with the hub but in my home assistant only the hub is showing up not the Aqara switch. I see above most of you have added Bluetooth sensors or motion Zigbee sensors has anyone even tried buttons/switches?

Switches don’t appear as entities (except for the battery status). A press on the button is exposed as an event. In the latest versions of HA you should be able to click on the Integration, select the device and use the prompts at the bottom of that page to create and automation that triggers based on the press of a switch.

Manually, you could go into the Developer Tools - Events and subscribe to the Xiaomi Events. When you press the button you should see the information come through in json form.

1 Like

Hello all, was anybody able to add bluetooth sensor using this method? My home assistant is able to recognise gateway and i was able to add it as homekit accessory. Due to fact that this gateway has bluetooth it’s able to act as BLE gateway and successfully discovered my temperature and monitor sensors (LYWSD03MMC) but i’m not able to add them to home assistant.

While normal sensors detects proper, has anyone tried aqara cube integration? I was not able to get it into home assistant, would assume homekit might not have cube compatibility but would love to hear from you guys.

Dear All, I would like to ask for your help. My home assistant is not able to recognise the multi mode gateway. I could not find any device under the HomeKit component. Thanks in advance for your help

Hi,
Any update on this? have you succeed to view bluetooth sensors in homeassistant ?

can the multimode gateway be blocked from the internet like the old gateway and still function?

Mini review:

I have one, but as of now I decided not to use it. At least until the software matures a bit.

Yes, it can be added to HA via the HomeKit integration. But the good news stop there.

It doesn’t expose to HomeKit a lot of things. For example water leak sensors, although Aqara, they are not exposed. I also have Aqara movement sensors, they are exposed as movement sensors, but not the illumination sensor.
Even what works, it’s unusable. The door/window sensors are reporting the status after ~5 minutes. And not only in HA, but also in the Mi Home app. The same sensors linked to the old gateway, in HA change status instantly.

Another annoying thing, the new hub only having a beeper, sometimes you don’t know why it beeps. And it does beep, out of the blue, without anything obvious happening. And there is no notification in the Mi Home app. I disconnected it after it started beeping one afternoon, every 10 minutes or so, and I could not figure out why.

As of now, the old CH region gateways in LAN mode are a better option.

3 Likes

I can confirm almost everything, except reporting to MiHome and HA. In my case I have Aqara Motion sensor, and report time to MiHome is extremely fast, but like 20-30 seconds to HA. Also battery status is unchangable at level 95% (44% in reality).

1 Like

My motion sensors are the Mijia ones, not Aqara.
And I’m on chinese mainland server. Lately those are absolutely overwhelmed, the Mi Home app is barely functioning. I also have a Xiaomi camera and there are instances when I simply cannot connect to it.
I’m hoping they are working on upgrading their infrastructure. If not, soon it will grind to a complete halt.

Hi,
I has bought one of that, but I share the previous things:

  • End to end: there is very long latency on update
  • Bluetooth things aren’t shared via HomeKit interface
  • Restrictions on usable Zigbee devices

But I found maybe a bug… :confused: my test env runs in a VM on a laptop. Sometimes I hear it’s fan, but while I enabled the HomeKit integration for this GW the HA runs one CPU core on 100%.

And I found a candy in the logs:

WARNING (MainThread) [homeassistant.components.homekit_controller.connection] HomeKit controller update skipped as previous poll still in flight

If I restart the docker container of the HASS the things work again.

So, now I think I have a fresh new GW for sale :stuck_out_tongue: :frowning: