Xiaomi philips zhirui adjustable color temperature downlight support

Tags: #<Tag:0x00007f3269fee9d8>

Hi, I have not found any reference on this wifi device:
xiaomi-philips-zhirui-adjustable-color-temperature-downlight

I have 5 o them and following the miio guide I’m unable to discover all the lights:

How can i try to find token and add them ?

Have 20 of these so would also love to get them working. Please let me know how you go.

Have you tried this https://www.home-assistant.io/components/light.xiaomi_miio/

I have the bulb version which works HA

If you mean this product: I got them working by following the instructions mentioned by jimpower, and manually setting the model to philips.light.bulb.

Yes @danielperna84 I ment that product.

Thanks for your hint: I have added sucessfully the lights.

using miio discover does not show me the token.
imagen
How can I get it?

solved
I have followed the steps indicated in this link in the section #Windows and android:


using the version My Home 5.0.19. In higher versions it does not show the tokens

Cant get the token out, i have installed 5.0.19 and succesfully control bulbs through it, but miio discover doesnt show tokens :confused: Is there other way to get it ?

I have fetched tokens via iOS app backup following Xiaomi Mi Robot Vacum link

Hi webartoli.
I’m thinking to buy these downlights, do you know if there is a way to make them work with Phillips hue dimmer switch thru home assistant or any other switch? Thanks in advance.

As I am seeing a lot of people trying to find a solution, I will detail what worked for me. Following the guide mentioned by @jimpower, install node.js, and use the commands mentioned in the doc. For best results, reset all your Philips miio lights (I used Philips downlights here), connect to the ad-hoc wi-fi network broadcasted by the light itself, and run command miio discover --sync. This will list out something like the following.

Device ID: 920XXXXX
Model info: philips.light.downlight
Address: 192.168.4.1
Token: 7c1xxxxx5xxxxxxxxxx019xxxxxxxxxx via auto-token
Support: At least generic

Now, that token part is what you need. Copy this safely. Now add the light to your Mi Home app, and continue configuring as per the requirement.

I hope this would help someone who would stumble upon this problem in the future.

1 Like

@webartoli Can you check which firmware version you have?? I just bought 4 extra ones (upon having 26 up and running) and they won’t accept HA. They are offline and there is nothing i can do to get them to show up :frowning:

Old downlights: 1.3.0_0021
New downlights: 1.3.9_0024

Are you able to fetch the token? Your problem indirectly says you managed to fetch tokens, added them to the config, but they are not showing up in HA. Correct? In some cases, the token changes once the device is connected to wifi.

Thanks for the reply,

Yes the token was no problem, I use miio discover. Is that new?? None of my old lights did that, could be the firmware version. Can I get the used token? @nithino

Miio discover will not be able to fetch a token once the device is paired to the mi home app. You can use a rooted phone to obtain this token using older versions of miHome. I am not sure if this is a problem caused by a new firmware update. I have old firmware lights. Never updated the firmware.

I just wish i had bought extra lights 2 years ago!

I’ll try it with a rooted emulated android maybe i can get the older version of mihome to work on there!

It worked! I had to search manually through a .txt file (ended up just searching the ip’s) and got 4 tokens that weren’t in my config. Added them, switched them around a bit and now i have all 30 lights working! Thanks for the help.