Xiaomi sensors disconnect from the network

I have a problem with Xiaomi devices. I had z2m for two years without any problems with the CC25XX ccordinator. About two weeks ago, the Zigbee network stopped working. I had an old z2m 1.18 there. I uploaded the latest one but the network didn’t work. So I bought Sonoff ZB 3.0 plus. I reconfigured the network, but all Xiaomi devices gradually become unavailable, especially PIR sensors. I tried to install HA completely anew on the test RPi4, I added mqtt and z2m, but Xiaomi devices do not work even on a fresh installation. I’ve tried everything and Xiaomi doesn’t work. Can anyone advise what to do with it?

Try the obvious. By new batteries for it.

I measured the batteries and they are OK, but I tried to replace them just to be sure, but it didn’t help at all. When I look at the map, all Xiaomis do not have a link to the coordinator. They work for a while and then I have to steam them again. However, Tuya devices work without problems.

I have few xiaomi devices, some smart plugs and motion sensors. No problems with it.
You will have to dig a little bit deeper in it. Maybe you have some blind spots in your zigbee network, maybe you don’t have enough routers or you need zigbee repeater. Try to put any of those xiaomi devices closer to the coordinator just for a test. If they are working than you will either have to buy a zigbee repeater or buy a few devices that acts as a routers.
A one more thing. in my experience good wifi coverage is helping a lot for stability and avability of zigbee devices. Since I added another router to my wifi mesh, zigbee network became more stable. From time to time my switches disconnects from the network but they reconnect on it’s own. Battery devices never disconnects from the network.

I have 4 Tuya sockets and an Ikea repeater in the network. The network worked perfectly well for 2 years, but after the necessary replacement of the coordinator for Sonof 3.0, I am not able to start a functional network. That’s why I tried a clean installation where there is only MQTT and z2m to check the functionality, and I’m very surprised that it doesn’t work even on a clean installation. The number of Zigbee and WiFi elements has not changed.

I accidentally run esp firmware on my old zigbee stick. Zigbee network was down for a week till I got new one. I bought it from here.
I pluged on new stick, reboot comp and everything was paired automatically. I didn’t have to repair any of my 80+ zigbee devices.

Hey there, you ever solved this? I encounter the same problem with HA Yellow and with a Sonoff Dongle E, too. The sensors in question are Xaomi Mijia brand identified as lumi.xxx. Got only a few and for sure 4-5+ years old, china version, Contact, Motion, Button.
Aqara/Tuya etc work perfect but these refuse to work with zha/z2mqtt no matter what I try.

Would be interesting to know what’s wrong with Xiaomi device.
I have a tasmotized sonoff bridge with ZHA and the zigbee network (with various device of various makers) works with the exception of two lumi PIR, which require reconnection/rediscovery at least once a week