Xiaomi sensors never update

I have a fresh installation of HA. I added integration with Xiaomi hub (xiaomi_aqara), which has two temperature/humidity sensors registered with it.

The issue is, the value from those sensors is only ever read once - when HA [re]starts. When it’s running, it seems to never poll them, because ex. 40 minutes after HA restarts I open the reading of a sensor and it would read ‘40 minutes ago’.


  • Xiaomi hub does’t show up in Integrations or Devices sections. Should it? Its entities do show up in ‘Entities’, though.
  • In ‘Entities’, there’s an ‘Updater’ entity which has status ‘Unavailable’.

I have tried to set up an automation to re-read sensor value, as suggested in this thread. However, I don’t even have the ‘python script’ service in the service list. I still added the automation to the automations config, but it didn’t help - it does run, but I’m not sure how to check if it runs successfully or fails.

Appreciate any help! Thanks.

I have also tried homeassistant.update_entity, which had no effect.