Xiaomi Sherlock Smartlock

I had a few different issues. Try resetting the fobs that won’t add. Hold down the the button until it flashes alternative colors, immediately release the button, and then push the button again. Then re-add. That helped with mine…

Thanks alot for the hint, but it didn’t helped . I think my problem comes from the Android app. After the first fob it gets stuck when I want to add another one . It never goes into the mode where it searches for a new key :frowning:

there is a beta version of the app, you may try that one

Thanks alot for the suggestion. Do you know how I can request access to the beta application ?

Write an email tro them and ask for it

[email protected]

Yes, email them for support with your specific issue. They are pretty responsive and seem to know the fixes. Write really simply as I think it all goes through a translator.

I’m dumping my exchanges here in case it helps someone.

Thank you for quick response.

This fixed it :blush:.

From: cxj <[email protected]>
Sent: Tuesday, 23 April 2019 8:18 PM
To:######### 连骆鑫 <[email protected]>; [email protected]; [email protected]
Subject: Re:RE: Re:Issue setting up Sherlock S2

Intelligent key recovery factory settings: long press button until the traffic lights flashing alternately immediately release the button and then press the button to release.

Hello, please check your operation method is correct.





------------------ Original ------------------

From: ########

Date: 2019年4月23日(星期二) 下午5:49

To: "连骆鑫"; "[email protected]"; "[email protected]";

Subject: RE: Re:Issue setting up Sherlock S2


Now I have another issue.

I bought 4 Smart keys with my Sherlock S2.

2 were added, but then stopped working. The LED still functions as expected, but the door doesn’t respond. I tried to reset them by holding down the button, then I removed them from the app. But now I can’t add them back again. Maybe there is something you can reset on your side for the 2 faulty smart keys so I can use them again?

I was able to add a 3rd one that I hadn’t unboxed yet.

Can you help?

From: ############
Sent: Sunday, 17 March 2019 4:01 PM
To: 连骆鑫 <[email protected]>; [email protected]; [email protected]
Subject: Re: Re:Issue setting up Sherlock S2

Ok. Yes the device has disappeared from app which is good. I will reset and try to set up again.

From: 连骆鑫 <[email protected]>
Sent: Sunday, March 17, 2019 3:59:28 PM
To: ######## [email protected]; [email protected]
Subject: Re: Re:Issue setting up Sherlock S2


I have already helped you untie the success. You can restore the device to factory settings. Press and hold the function key 6S until the indicator light flashes red and green alternately





------------------ Original ------------------

From: ########

Date: Sun, Mar 17, 2019 12:43 PM

To: "连骆鑫"<[email protected]>; "[email protected]"<[email protected]>; "[email protected]"<[email protected]>;

Subject: Re: Re:Issue setting up Sherlock S2


I am using the most recent app but I’ll check again.

From: 连骆鑫 <[email protected]>
Sent: Sunday, March 17, 2019 3:40:19 PM
To: ########## [email protected]; [email protected]
Subject: Re:Issue setting up Sherlock S2


I can help you untie the device. You take a photo of the QR code in the battery compartment.

APP question you can see if the app store has an update。





------------------ Original ------------------


Date: Sun, Mar 17, 2019 12:34 PM

To: "[email protected]"<[email protected]>; "[email protected]"<[email protected]>;

Subject: Issue setting up Sherlock S2

When I tried to set up my Sherlock S2 the set up process failed.

I have tried reinstalling the app and resetting the device.

My lock shows as testing not complete but when I try to test it says it has been reset and needs to be reinstalled.

But it is not possible to remove the untested lock or reinstall the lock.

I think I have tried all options in the interface and nothing works.

This is very frustrating.

Maybe if you reset my account?


1 Like

Agreed, try to be as simple as possible

For those interested, I’m looking into, but struggling with fast arrival presence detection to open the lock.

Hi, anyone has tested a way to open/close/read battery level or state with an esp32 and openmqttgateway acting as BLE?

I think you’ll need to do the fob hack…

But I would like to know battery state and status… Everything available in the app in order to feed mqtt

I don’t think anyone has cracked how to get battery status or true state. Some of us are getting state by using a door sensor within the lock.

Hi, where do you can get the plastic bag for the circuits? How do you name it?

Congrats!!! beautiful solution!!!

Plastic bag? That’s just transparent tape on the BT keyfob and a normal transparent shrink-wrap on the esp32.


Keyfob + wemo D1 mini

1.- I’ve noticed that the GPIO needs to be HIGH STATE as normal, and when you want to activate it, you need to write LOW_STATE in the GPIO.
2.- 1 pulse from high to low close the sherlock, 2 pulses from high to low open it…
3.- If I put HIGH STATE as normal mode since Boot, there’s a glitch that tries to close the door when the ESP8286 boots

Am I right?

I did. Then I try in the next day and i could config another.

need your help urgent
my sherlock stop working after the app ( have Samsung 7 ) was updated - its worked fine for 4 mounts
its not opening by hand or by app
when try to connect it again to the app i get massage : “device already bound,please delete it first”
how do i reset it or delete it ?

1 Like

Please check in this forum, I remember to read a post about how to reset it

You have access from the inside?
You can dismount the black knob, then turn the key manually.

Probably the battery is dead? Remember that the internal key has to be in horizontal position, in order for an outside key to be able to open/close