Xiaomi stopped reporting to HA


I have a Xiaomi temperature and humidity sensor that hasn’t been reporting to HA for some time now. I’m unsure when it stopped, but I only noticed it a few days ago. I tried rebooting my HA several times, but it didn’t fix the issue. Can you suggest any solutions?


I’ve had the same with my Xiaomi wifi power plugs. They were working up until a week ago and then became unavailable. I tried deleting the integration and re-adding, and they were found, but still unavailable.

I had them paired to a Xiaomi hub, which at the time had to be registered to Chinese Mainland. I thought maybe that was no longer a requirement, so I deleted it from the Mi Home app, and switched to my region (where I have some other Xiaomi devices). When trying to re-add the hub I got an error saying it’s region-locked, so I went back to add it again to Chinese Mainland. However, now it won’t add, and gives the error “No authorization to access the local network”. So it seems I now have a few white plastic paper weights.

EDIT: I found that by turning off “mobile data” on my phone, I could re-add the hub. Now one of the power plugs is online, but the other remains unavailable.

1 Like

The problem is with blutooth and OS10.x. I was able to fix it running the following:

ha os update --version 9.5

You can find more information here, but it is not only for blutooth: Bluetooth failing after upgrade to HAOS 10 on Raspberry Pi

Thanks heaps, turning off mobile data is what helped me reconfigure a Smart Air Purifier 2 on my iPhone 14 Pro.
Without your tip, it was an even heavier paperweight than your smart plugs! :wink: