Yale Assure Lock SL with Z-Wave

My Yale its been like this for quite some time now. I’ve done many factory resets, got a ZWave extender, and still…

Do you have a good Z-Wave mesh already established in the house? And are you adding it with Security? I’ve found that if you don’t to both these locks don’t function very well. I have three and the key is build out a good mesh FIRST and then add these in.

I have other devices and they are connected just fine, just the Yale is having issues.

The older locks that use the old security protocol S0 use a “whisper” setting to join the zwave network and need to be very close to the stick on initial inclusion.

1 Like

This issue: [question] Unknown manufacturer 0xXXXX listed for device in database · Issue #4596 · zwave-js/node-zwave-js · GitHub

Is basically the same thing for a Schlage lock. (I’m having this EXACT issue with one of my Schlages) While this is not exactly your issue (Because, Yale) it should help you with collecting the correct data and the process to submit it and the right location to get it looked at.

tl;dr, anything going wrong with the interview can make this happen - figure out why the interview isn’t working. If you cant figure it out - capture a debug log during the interview and open a ticket at the link above.

So I was able to establish a new connection. I had to remove it from the door and set it up 3 feet away from the Main Node. It didn’t work when trying to use the extender.

The Yale does responds to ping commands

Any idea how can I make this work?

The node is dead. Note the dead robot icon.
Try pinging the node from zwavejs2mqtt rather than HA.

Im pinging from here and it does reply.

Is there another way to send the ping? I only know two ways. Is



No looks like you have installed 2 zwavejs addons BAD.

Remove one of them.

Yes, that’s actually not the first time I notice I have more than the “Z-Wave JS to MQTT” addon. Is there a reason why the other one keeps installing itself? I’m sure it will come back automatically.

You checked the “Install addon” option when you configured the zwavejs integration.

Review the steps here to resolve this issue.

nice, thanks @firstof9


HA → Devices & Services → Integrations → Hit the three dots for settings → click on Disable

was this the right way? Now i cant see my entities tho they are available from the Z-Wave JS

Follow all the steps:

  1. Disable the Z-Wave JS integration. Do not remove the Z-Wave JS integration or you will lose all device and entity naming. This will automatically stop the official Z-Wave JS add-on.
  2. Note your network security keys from the official add-on.
  3. Install and configure the Z-Wave JS to MQTT add-on, including setting the location of your Z-Wave device and the network security keys. You already completed this step.
  4. Add the Z-Wave JS integration again (even though it is still installed), and uncheck the “Use the Z-Wave JS Supervisor add-on”. Enter the correct address for the community add-on in the URL field in the next step.
  5. Uninstall the official Z-Wave JS add-on.
  6. Enable the Z-Wave JS integration.

Yes, thanks! All good now! Thanks @firstof9

1 Like