Yale locks not acting like "locks" on HA dashboard

For the life of me, I cannot seem to figure this out. Why don’t the Yale locks I have show up as “locks” (with the appropriate controls)? New to HA (only been playing with it specifically the last week), but not to z-wave.

Before anyone “goes there”, yes, they are securely included and my network key is correct. I can see status updates from them, and the OZW log shows them talking securely, no complaints. Note, this is Hasspian on a Pi w/ an Aeotec Z-Stick (gen5). I paired the stick via the Sigma controller s/w to my primary controller (HA has to secondary, as the primary (alarm panel) doesn’t play well with others), then got the key from that pairing to plug into HA. HA is “learning” the nodes from the stick, and it properly ID’d everything else (4 dimmer modules and 2 Aeotec repeaters), and the locks are ID’d as Yale locks, with all the expected stuff under Z-Wave Configuration (ie, all the device-specific config stuff, user codes, etc), but the Dashboard just shows “ready” and “alarm-level” and “alarm-type” “sensors”.

Very confused…

This is what I see on the dashboard: (note, the “indicator” ones are labels for the dimmer modules… don’t ask :slight_smile:)

The more I dig, the weirder this gets. HA can read the user codes, which I assume is a part of COMMAND_CLASS_USER_CODE (which requires secure comms per Yale’s documentation), and the locks show the proper config options, but the lock.lock & unlock services aren’t registered, and of course, I don’t get the panel for controlling the locks. I’m guessing this probably due to how they were “learned” by HA (from the stick, as this is a secondary controller). I tried resetting the zwave configs (nuking zwcfg with HA shut down, so it reread the devices with the network key already configured), no change. Again, as it’s a secondary controller, I can’t unjoin/secure rejoin the locks to HA itself.

Does anyone know any way I can “force” HA to get these “fully” recognized as locks in this situation? An option to work into a config somewhere? I’m down to digging through code, but so far, I haven’t found anything. :frowning:

If you go to Developer Tools > States and filter entities by “lock.” does it show anything?

Here’s what mine looks like. I renamed it from the defaula assa abloy name in Configuration > Customization (and not Z-wave).

Here’s what it looks like in the Z-wave control panel.


And here’s what it looks like on a Lovelace Glance card. It accepts lock/unlock commands.


Nope, no lock.[anything].

Hmm. Must have to do with the secondary setup. Not sure about that…

I had this exact issue last week when I got a new Conexis lock. It was my first ZWave device so I tried out the stick and lock on a spare raspberry pi that wasn’t being used for much. On the pi, no lock entity showed up and it had me confused. Tried a few things, but didn’t get it working.
Eventually just put my zwave stick into my Mac where I have my production home assistant instance running, and it all started working perfectly there.

Not sure that’s much to go on, but it seemed like an issue with zwave on hassio/raspberry pi

any luck with this? I have similar problem with my yale lock but mine is a YRD426 (shows up as a YRD446 in HASS). I get 2 sensors and a lock show up but no status changes and I can’t control my lock. Doing my head in.

Unfortunately, no. Yours sounds a bit different, though. I’d suggest verifying you have your network key configured, and if so, make sure your HASS is in the lifeline association (association group 1) for the lock.

thanks for the response. I have managed to find a solution after much messing around. If interested it’s here.