Yale Z-Wave

I’m new to HA, so I hope I’m not asking a basic question.
I managed to connect Yale Assure Lock to HA Z-Wave JS.
The lock shows an unknown status and it doesn’t respond to lock or unlock buttons. Even I tried to lock/unlock through Node-RED with no luck.
I tried to exclude/include the lock several times with no result!
The lock was working flawlessly in Hubitat environment.
Am I missing anything here? Is there any specific configuration that I have to apply to kick off Yale smart lock?
Really appreciate any help here

Added as secure or just added?

You need to define a Network Key and add it as Secure.

Thanks for the reply and I apologize again for asking basic questions.
So the lock doesn’t work without defining a network key and add it as secure, unlike GE switches and other Z-Wave devices?
I have to dig down and find out how to add a secure node, I have no idea so far! Appreciate sharing the procedure for that.
Can I have unsecure and secure z-wave connections at the same time? I dont want to change the 50 GE switches that I already migrated from Hubitat.

Yes. You can mix

Security product always must add as secure
Switches and the lugs not needed

How can I configure secure Z-Wave with network key? I’m unable to find related documents

You can also use sites like this one to generate the required data, just remember to put 0x before each pair of characters and a , between them:

# Example configuration.yaml entry for network_key
  network_key: "0x2e, 0xcc, 0xab, 0x1c, 0xa3, 0x7f, 0x0e, 0xb5, 0x70, 0x71, 0x2d, 0x98, 0x25, 0x43, 0xee, 0x0c"



Ensure you keep a backup of this key. If you have to rebuild your system and don’t have a backup of this key, you won’t be able to reconnect to any security devices. This may mean you have to do a factory reset on those devices, and your controller, before rebuilding your Z-Wave network.

After you have added the key, you only need use “add secure” when adding device to Zwave network

This is the incorrect method for zwave-js, you do not add this to your configuration.yaml.

@walmzd Please follow the directions in the documentation on where to enter a network key.

Thank you very much for the input. I was able to set up a secure connection after resetting the lock to its factory setting.
The question now, how to setup a user code? :slight_smile:

In HACS you can install KeyMaster it’s an integration designed for managing lock keys and sending notifications.

I installed HACS and KeyMaster, but it there’s no option to kick off this integration or add locks to it

Add KeyMaster from the integrations menu, if it’s not showing up press refresh on your browser then it should show up.

1 Like

It does show up, but it doesn’t give any option to add any lock. When I click on the keymaster integration, it shows a note that I have to use Entity Registry to rename each entity belongs to the device and append _LOCKNAME to it.
I’m unable to find “Entity Registry” tool, I’m not sure if changing the entity name will resolve the issue or not?
I’m totally confused and searching for any info with no result.

You don’t have to rename anything. Are you not seeing any locks in the drop down box?

Check the wiki.

No I’m not

If you have no lock entity, then you have no locks. Check Dev Tools → States for locks.

The lock entities are there and I’m able to lock and unlock via dashboard without the need for keymaster. I’m trying to set up user codes, so I’m trying keymaster. But keymaster appears not work properly. I’m unable to see any dropdown menue for the locks I have in my Z-Wave network

Do I have to apply any configuration to “Configuration.yaml” file?

1 Like

Ohh…I have to add the integration at configuration :grinning:
I was trying to access it at HACS!

Sorry for reviving this topic, but I wanted to share my experience with the Yale Assure SL deadbolt since I faced a similar issue after migrating from the deprecated Z-Wave integration to Z-Wave JS. Since this thread doesn’t really have a proper solution, I am sharing what worked for me.

The lock itself was recognised by the Z-Wave JS integration, but it was not working as described by the OP. As others have mentioned, this is likely due to the network key being auto-generated by the Z-Wave JS add-on, and being different from the original network key from the deprecated Z-Wave add-on.

Here are the steps I followed to get the device working again:

  1. Take the lock offline by removing one of the batteries

  2. Locate the Device in HA, and in the “Device Info” pane, select “Remove Failed Device”. This will delete the devices and entities so that you can start fresh. You can of course skip this step, but I didn’t want any orphaned entities after I add the lock again, so I just did this anyway.


  1. Insert the batteries into the lock and bring it online

  2. In the Z-Wave JS integration, select “Remove Device” and put the system into Exclusion Mode by clicking “Start Exclusion”


  1. Back at the lock, enter the master PIN and go into exclusion mode (instructions can be found here).

  2. The lock should be excluded from the Z-Wave network after step 5. Now back in the Z-Wave JS integration, select “Add Device” button to put HA into inclusion mode.

  3. On the lock, go into inclusion mode. Instructions can be found in the above document shared in step 5.

The lock should now be included with all the functions. During the interview process, I manually locked and unlocked the lock to make sure it doesn’t go to sleep.

Hope this helps for anyone having the same issues.