Yamaha Music-cast Network Receiver Listed multiple times

hello, I just had HA set up. I wanted to add my Yamaha receiver to Home assistant and added the following to my configuration.yaml file

#Yamaha AV Reciever

  • platform: yamaha_musiccast

However, in my HA overview page, i see three instances for the Yamaha receiver with one of them with “(main)” at the end of the receiver name. I can control the receiver with any one of the instances. Is there a way to remove the duplicate entries?

Thanks a lot for your help.

Does your receiver have more than 1 zone? My Yamaha has 2 zones and each zone can be turned on/off independently. Also, if you have discovery on, it will find your receiver. So in theory, if you have discovery and platform: yamaha_musiccast in your config, you would get one media device for each zone and 1 media device you added in. I just left discovery on and removed the platform which gives me media_player.yamaha_receiver, and media_player.yamaha_receiver_zone_2.

I have it set up with a single zone only. So to test it out, I disabled the yamaha_musiccast in my config file. Now, the instance with “(main)” at the end doesn’t show up, but still two instances are showing up.

can you take a screencap of the 2 media_players that are showing up in your States tab?

Hi, I am still making my way around HA, I am not sure which one is the States tab. But this is how it shows up in the main “Overview” page.
This image is with the yamaha_musiccast disabled in my config file

This image is with the yamaha_musiccast enabled in the config file.

Ok, so i figured out the states tab. Here is what it shows

sorry for the late response… I never got a notification that you replied! Anyways, I’ve seen stuff like this before when the IP of your media player changes in your internal network. If you have discovery on, every time the IP changes you may get a new media_player device. Try to make your meida player a static IP. I do not know how to remove old media player devices… maybe clean out your history.