Yeelight Brightness Step causing light to become unavailable

Tags: #<Tag:0x00007fc3ec95ffa8> #<Tag:0x00007fc3ec95ed88>

Hi all,

I’m utilising my Philips Hue Dimmer Switches to step brightness up and down with the two middle buttons (2000 and 3000 respectively).

I’m noticing all my lights behave fine apart from my yeelights. They step up and down fine until they reach the lower and upper limits. Could this be due to Yeelights not being able to handle brightness_pct values above 100 and below 0?

Models I have are the RGBW bulb and CWWW oyster ceiling light.

I’ve also tried templating this the old fashioned way with the same result.

What kind of workaround could there be? floorlamp is my yeelight and lounge_light is my Philips Hue bulb that’s working fine.

step down yaml:

- alias: Lounge step down brightness
  initial_state: 'on'
  trigger:
    platform: event
    event_type: deconz_event
    event_data:
      id: lounge_dimmer_switch
      event: 3000
  action:
  - service: light.turn_on
    data_template:
      entity_id: light.floorlamp, light.lounge_light
      brightness_step_pct: -10
      # brightness: "{{ states.light.floorlamp.attributes.brightness | int - 25 }}"

step up yaml:

- alias: Lounge step up brightness
  initial_state: 'on'
  trigger:
    platform: event
    event_type: deconz_event
    event_data:
      id: lounge_dimmer_switch
      event: 2000
  action:
  - service: light.turn_on
    data_template:
      entity_id: light.floorlamp, light.lounge_light
      brightness_step_pct: 10
      # brightness: "{{ states.light.floorlamp.attributes.brightness | int + 25 }}"

logs:

Unable to update device 192.168.xx.xxx, floorlamp: {'code': -1, 'message': 'client quota exceeded'}
Unable to turn the bulb on: {'code': -1, 'message': 'client quota exceeded'}

I’ve been having this problem too. I’m using the Mi Magic Cube rotation action to adjust the brightness. I may be wrong (I’m a complete noob) but I think it may be to do with limit to the amount of requests per minute (https://www.home-assistant.io/integrations/yeelight/). I’ve found bumping the percentage step to 20 & adding a delay (150ms) seems to work without fault. I’m calling a script for each action (See below)

Increase Brightness:

'1588882713296':
  alias: Living Room Lamps Increase Brightness
  sequence:
  - delay:
      milliseconds: 150
  - data:
      brightness_step_pct: 20
    entity_id: light.living_room_lamps
    service: light.turn_on

Decrease Brightness:

'1588882248824':
  alias: Living Room Lamps Decrease Brightness
  sequence:
  - delay:
      milliseconds: 150
  - data:
      brightness_step_pct: -20
    entity_id: light.living_room_lamps
    service: light.turn_on

Hope this helps.

1 Like

Thanks mate. I tried your suggestion of adding a delay, but found the same issue occuring.

However, your link to the yeelight integration documentation helped me out as it reminded me of the music mode workaround. I’ve since enabled music mode on the light and it’s working as expected!

Thanks for that.

Ever found a solution for this?
I see the same, even with a delay of 500ms

Music mode was as close as I’d gotten. Took this as a learning to stop investing in yeelight and go for ZigBee or flashable tuya lights.

With a value of 6000ms , the MI Bedside Lamp 2 started to work as expected but 6 seconds really?!??
On the other side, the regular bulbs from Yeelight, work even without delay.