YeeLight bulbs stopped showing up in Hass entities


My YeeLight bulbs stopped showing up in Hass entities. Not sure why, I did not change anything, they show up with their correct IPs on the router, I can still control them through the native app. Hass even sees them in device_tracker (AsusWRT). But they just don’t show up in hass.

It happened before I did anything. While trying to fix it I tried rebooting router and restarting hass, and updated hass to latest version (

Any ideas what could’ve happened?

Just in case, here’s relevant config:

  - platform: yeelight
        name: "YEE Room 1 A"
        model: color2
        save_on_change: True
        name: "YEE Room 1 B"
        model: color2
        save_on_change: True
        name: "YEE Room 2 A"
        model: color2
        save_on_change: True

But I did not change it, it worked fine.

I have this issue now and again. For some reason the lan control in the app goes off. Maybe check that ?

What version did you update ha from ? There was a change in yeelight a little while ago

I did uncheck and check it again while troubleshooting.

It broke before the update, not after :slight_smile: Updated from 93.0 to 94.1

Even then I don’t see any changes in config I should do? Seems like it should work with what I have now.

Strange, no idea then sorry

Hi, same things happenes for me. Use the mi app. Remove the bulbs, re add them, check Lan mode, them allow ha to re discover them. You’ll see that their entity IDs change. Their names have changed. Something yeelightrgbblahblah to yeelightcolorblahblah…


Hi, thanks, I’ll try that. But why would HA care if I set them up directly by their IPs, not through discovery?

I dont know. Your symptoms are exactly like mine were. I had to update the mapping for my my friendly name in customize.yaml also…


Well no, my setup is different, you can see my config in the first post. It does not use yeelight mappings and names at all, it just looks them up by IP directly and assigns a name that I specified.

Yep, my config.yaml was very similar.

What do you mean here? I never used discover in the first place. It’s disabled for yeelight in my config

Have you reconnected removes and reconnected them via the mi app?

Yes. Still not sure how this would be a problem though

AFAIK the entity IDs changed. Try removing the ips and the manual config from your yaml file and let discovery find them afresh.

When I did this it found them again with the new format and all was good. I added the manual config back into my yaml file.

Do you recall what they used to be called? Mine are now:

They used to be like this.

This is from a back up before the disappeared.

Well, I removed Hass config regarding yeelight, then restarted it, and then enable it again and restarted again. Did not help.

And again, my setup is different from yours. I don’t use entity ID’s for Yeelights, I did not use Discover, I use direct IPs. If you had the same setup as me you would not need to use friendly_name inside of customize.yaml, you’d set your friendly name inside the configuration.yaml file.

Thanks for the help, but I think we have different setups

Maybe. Only other thing worth a try is delete from known_devices.yaml?

Yeelight is it’s own component now since a few releases ago. Mine are configured like this:

    - yeelight

# Yeelights
      name: Fan Light
      name: Meals Area Light
1 Like

Yes, that’s what I meant here although I though it was earlier than 0.93 when it changed

1 Like

Aaah, that’s probably it, I’ll try it, thanks! I remember now that I actually saw it somewhere in the changelogs and made a mental note to not forget to update it and… Of course I forgot about it :smiley:

EDIT: Yes, it works now, thanks, guys!