Yeelight in 0.115 not working

Does anyone know why the review of the PR is taking ages? The fixes have been done almost 3 weeks ago and still nobody has reviewed them. Anybody who runs Yeelights in different VLAN (which anybody should do by the way), cannot update to the newer versions of HA.

The documentation for docker states that host mode should be used

These below instructions are for an installation of Home Assistant Core running in your own Docker environment, which you manage yourself.

Note that Docker command line option --net=host or the compose file equivalent network_mode: host must be used to put Home Assistant on the host’s network, otherwise certain functionality - including mDNS and UPnP - will break. The -p command line option or the compose file equivalent ports: is not compatible with host networking mode and must not be used.


(first paragraph the warning part)

Thanks !! That was the issue. I missed this. So far, I never have had an issue. I am now in 0.116.4 :slight_smile:

I think I have the same problem, but I’m running Home Assistant as a VM on Proxmox. Any idea how I can add ‘–net=host’ somewhere?

Which flavor? If you use Home Assistant Supervised then, unless your yeelight are in a different subnet “by design”, then it should work.

Yes, Supervised and yes, the Yeelights are in a different vlan.

I run the same way, the HA OS image doesn’t need to be adjusted in this way.

I followed your guide to install it :slight_smile:

My lights are in a different vlan and that seems to be the problem.

In this case, I think you will have to wait for the fix to be merged into HA…

That’s likely.

Have you tried added them to directly to yaml, like this?

devices:
  192.168.1.133:
    name: Steps
  192.168.1.132:
    name: Hall
  192.168.1.134:
    name: Table
  192.168.1.136:
    name: Toilet
  192.168.1.138:
    name: Front Gate
  192.168.1.145:
    name: Downstairs
  192.168.1.149:
    name: B1
  192.168.1.150:
    name: B2

yes, like that

Thnx for the link, I will wait for that then.

I have restored to 0.114.4, so they’re working again.

That’s the “solution” at the moment…

Hey there! I am just trying to install an Yeelight light bulb and it does not work and I found this post.

I have set it on a VLAN as well.

I am trying to figure out how to set it and if the problem is related to the bug you guys mentioned.

Btw, do you happen to know a good tut on how to install this? I saw so many different ways and none of them work.

Thank you so much!

The PR solving the VLAN problem seems to be merged, finally. Let’s keep fingers crossed that this will make it into one of the 0.117.x releases.

If your Yeelights and HA are in different vlan, then, use 0.114.4 version. At the moment, it is the last version know to work.
As @ffm777 said, it has been merged and should be in 0.117.x.

I understand now. So this is the problem with the last versioning. I switched it to the same LAN and it works

Thank you so much!!

Any news regarding this issue?

I’m running 0.117.0. My home Assistant is installed on a VM Unbuntu inside a docker. And that is bridged to my LAN 192.168.200.0/24. My IoT stuff are located on a different VLAN 192.168.199.0/24 though. And well I can’t add my yeelights back to my home assistant. Everything was working fine in 0.114.4. I have removed the yeelight entries from my configuration.yaml file. I get the notorious “Failed to connect” when trying to add the lights manually in the integrations page.

Well, not really :slight_smile:
The fix has been merged into the dev branch. So, it should be then merged into the prod branch in an upcoming 0.117.x. When? no idea. Stay in 0.114.4 is the only option in your setup.

Hasn’t made it into 0.117.1. This is getting nerveracking… I’m also still on 0.114.4…