Yeelight in 0.115 not working

I am using yeelight bulbs and strips.
I am using the docker version of HA (not the supervised version).
When in 0.114.3 all my yeelights configured in configuration.yaml are working fine.
After upgrading to 0.115, all of them are unavailable. I still have the yeelight integration configured through yaml.
If I try to add the integration through the GUI, no yeelight are (auto)discovered on my network. Adding any of them through the GUI fails.
After a few other tests, I downgraded back to 0.114.3 and all yeelights are back…
Reading the Yeelight integration doc, it doesn’t say anything about a breaking change in 0.115. UI integration is new for Yeelight… without much success for me :frowning:
Any suggestion? Thanks.

1 Like

I have 4 Yeelight devices (1 white bulb, 1 color bulb, bedside and desk lamp) and all of them are working just fine. The only thing is I’m not using autodiscovery but have my lights configured manually.

Remove all the config from yaml for them

The change is listed in the all changes

image

I didn’t read I had to remove the entries in configuration.yaml. So, the 1st time, I didn’t.
Now, I have done it.

  1. Remove all yeelight in configuration?yaml
  2. Upgrade to 0.115.1
  3. Install integration
  4. Attempt to discover or add manually, both are failing

And nothing in the log…

If I start HA 0.115 with yeelight configued in configuration.yaml, I have this:

2020-09-19 07:12:15 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to get capabilities from 192.168.1.x: timeout
2020-09-19 07:12:15 ERROR (MainThread) [homeassistant.components.yeelight.config_flow] Failed to import 192.168.1.x: cannot connect

So, the same error whether it is coming from the config file or added through UI.

In the release note I have this:

Yeelight
The Yeelight integration now uses custom SSDP-like discovery instead of the mDNS discovery, since mDNS discovery is removed in new firmwares.

After this change, there will be no longer automatic configuration based on discovery. Users currently using that should set up all devices through UI.

(@shenxn - #37191) (yeelight docs)

Not exactly sure what it means…

It seems that I have encountered this:

and should be fixed by:

Let’s wait…

1 Like

The fix has still not been merged. Has anyone tried 0.116 to check if the Yeelights work again?

it was fixed in 0116.2

But why does the Github link still show “Review in progress”?

probably for a different thing, but they are working in 0.116.2 after a different pr was merged

But I’m suffering from the connection issue as my Yeelights are in a different VLAN. Anyways, will just have to wait for the fix to be merged…

I have tried 0.116.4 and yeelight isn’t working… Still the exact same symptoms as explained above. Unable to connect to yeelight when in 0.116.4 and it is working perfectly fine with 0.114.4.
What about those with the same issue? Is 0.116.4 working for you?

116.4 is fine for me. There was an issue because Yeelight library was upgraded but that was maybe fixed in 0.116.2

Yes, it is, in theory, fixed even if https://github.com/home-assistant/core/pull/40251 is not yet merged…
And for me I still can’t connect to any of my yeelight :frowning:
My yeelights are with 192.168.0.x addresses.
I am running HA core on docker
The host where the HA container is running is also in 192.168.0. subnet. I am running the container in bridge mode so 172.17.0.x subnet… Could it be a networking issue?

Are you running the Yeelights in a different VLAN than the HA instance?

No I don’t run a VLAN

If you are using HA Core with “bridge” mode then, even if you don’t want it :slight_smile: they are in different subnets and the routing between the your “normal” LAN and the internal docker network is done by docker. Is that the case? Which HA environment are you using?

Supervised on Debian

Could be related… The network setup might be different from HA Core.

I don’t see how.

The docker network setup between supervised and mine. It looks like it is now using some multicast between HA and yeelight. I don’t know if there is additional stuff in supervised on this aspect…