Yeelight integration not working

My Yeelight 650 (ceiling4) stopped working correctly in HA in some scenarios.
While it does work with native yeelight or mi home app on my phone, it is not possible to turn the light on or off in sequence.

How to reproduce:

  1. Turn on nightlight using Yeelight native core integration
  2. Turn off nightlight using Yeelight native core integration

Expected result: the light is turned on and the turned off.
Actual result: the light is turned on and never go off.

There is a log in the journal:
Error when calling _async_set_music_mode for bulb Yeelight Ceiling4 <id> at <ip>: {'code': -1, 'message': 'method not supported'}

It looks like the integration tries to set music mode and fails for some reason.

If I restart the HA while the light is ON, I can turn it OFF but then cannot turn it ON again, looks like only the first command works.

I tried to remove integration from ‘integrations’ and add manual configuration in the configuration.yaml, with no success.
I also tried to change use_music_mode setting in configuration from false to true, but it does not help.

The configuration I use:

      name: <name>
      transition: 1000
      nightlight_switch_type: light
      use_music_mode: false
      save_on_change: true
      model: ceiling4

BTW, the following scenario works fine:

  1. Turn on the nightlight (using light.turn_on service)
  2. Switch mode (normal → nightlight, using yeelight.set_mode service)
  3. Turn off nightlight (using light.turn_off service)
1 Like

same here! how annoying!