Yeelight led ceiling light compatible with HA


#21

It gives a lot of light. It has a nightmode whats better suited for a normal house but HA overrules the setting :frowning:


#22

Care to share what you did to make it work? Are you on the Mainland China server in the App or another server? Any specific configuration you added to recognise the light? Cheers @michielvdenberg


#23

Hi,

I’m using the Yeelight app, Add the light there, ive given it a fixed ip and then added it to HA using the yeelight component.


#24

If you want to use night/moon mode. put it in moon mode using the app and then you can control the brightness whit HA. dont use Colour because it will reset to normal mode.


#25

Success! Ok, here’s what I did in case anyone else is reading this:

I originally added the ceiling light into the Mi Home App which had LAN enabled (developer mode) but that didn’t allow control through HA. I installed the Yeelight App but couldn’t find Lan Mode from that app. At this point I’m not sure if I just missed it or if the following steps made the difference but I’ll detail them in case… In case you don’t need to do the following, if you want to enable LAN in the new Yeelight App, choose the device then down on the bottom right there is a symbol that looks like a triangle with a line under it. Select that then bottom right of that is the LAN mode option.

If that isn’t showing then try the following:

Delete the device from your Mi Home app
Download the Yeelight App
Sign in under Mainland China
Reset your ceiling light (switch on off 5 times till it “pulses”)
add device in Yeelight app
enable lan mode as above.
Voila, control is now available in HA
Funnily enough I can add it to Mi Home now again and it works fine in that app too now

All possible I missed it in the Yeelight App the first time I did it but I thought I had checked everywhere!

Now to set up the automation and different modes/scenes for day/night mode. No doubt that’ll take me days too :slight_smile:


#26

Good the hear it works. :+1:


#27

Yeelight Ceiling does not support modes, and has wrong white color scale (works only 50%), Also would be nice to have Moon Mode support. ps latest firmware and latest hassio


#28

Yeah, I second that. It works but brightness and color temperature don’t work very well.

Hope someone can fix that.


#29

Hi all, I bought a yeelight led ceiling lamp moon (YLXD01YL). This is my first smart light.
I added it to my yeelight app, assigned a static ip via dhcp settings, updated the firmware to 1.5.5_0178 and enabled the LAN control function.

then I added this to my configuration yaml:
light: !include lights.yaml

and this is my lights.yaml file
# Luci
- platform: yeelight
devices:
192.168.1.180:
name: Camerina

HA wont discover it. no lamps or controls shown in my default view.
Am I missing something? thanks for your help


#30

I just needed to reboot the light.
now it works, and can also be autodiscovered, but as unknown mi device.


#31

Still the same for me, even after 0.64 update (HASSIO). I have 3 ceiling lights, all come up as UNKNOWN, and throw “Unknown miio device found” errors in the log. They do work fine when configured manually, but the log errors are really annoying :frowning:


#32

I have the same situation.
@Igor_Jurisic you have the ceiling light? When you click on the lamp you can chose the RGB palette, for my this is a bug.


#33

Yeah I can also see the color wheel, and the color temp slider behaves a bit strange. But other then that discovery is the problem for me. Apparently it is related to netdisco which hasn’t been updated for a while.


#34

Hi, I’m new to Home Assistant and have the same problems. The Yeelight Ceiling Light does not work 100% as it should and the log is full of errors - auto discovery works for me, though.

Worst thing for me is that I cant get moon mode to work in automations.

I found this in yeelight forums:
{“id”:1,“method”:“set_scene”, “params”: [“nightlight”, 10]
//10 is brightness value

So it should be possible…


#35

For the moonlight mode please create an issue here: https://github.com/skorokithakis/python-yeelight

As far as the underlying library supports the moonlight mode it will be easily integrated into home assistant. I will care about if you provide some support / testing.


#36

Hi @syssi,

Maybe you can help me out, since I’m fairly new at HA (started using it about a month ago).
I also have 3 of those ceiling lights. They do work, but they throw errors in the log every 5 minutes or so (unknown miio device found), so it’s packed with errors all the time. I can’t disable it via discovery selectively either. Then there are the problems with it showing color wheel, color temp and dimming seems a bit off as well.

TL;DR, it was pointed out to me that the problem is the netdisco component (that needs to be updated), so I’ve tried asking there but there doesn’t seem to be any activity https://github.com/home-assistant/netdisco/issues

In your previous post you pointed to the python-yeelight libraty. Is that the same as official yeelight component for HA or something else?

Confused noob here, so sorry for the long post, I just don’t know who else to bother in order to fix support for yeelight (I’m sure there are tons of users with the same problem) :slight_smile:


#37

It’s hard to explain. Everything of your description is correct. Just some glue is missing:

Home Assistant has a component called “yeelight”. The component yeelight uses a 3rd party library under the hood called python-yeelight. All exposed features of the python-yeelight library can be easily integrated into the home assistant component. This is the way to go!

There is another component called “discovery” which uses a library called “netdisco” under the hood. This library throws the mentioned errors while discovering the yeelight device. I will try to fix it!


#38

I just added some background to the issue: https://github.com/home-assistant/netdisco/issues/179

I cannot help here. A release of netdisco is needed. If you aren’t using hassio you could change two lines of code on your own:

Search for discoverables/yeelight.py on your harddisk. :wink:


#39

Thanks a lot for the clarification @syssi :+1:
I’m still learning and you are extremely helpful!

Unfortunately I am using hassio, so I don’t suppose there are any workarounds, just waiting for the netdisco update?

Since I have very little experience with HA, out of curiosity…this update won’t take like a year, right? :slight_smile:


#40

There’s a new release of Home Assistant every 2 weeks and @syssi is awesome!