Yeelight led ceiling light compatible with HA


#1

Hi to everyone,

Please, can someone tell me if the yeelight led ceiling light is compatible with HA using the yeelight api?

https://store.yeelight.com/products/yeelight-led-ceiling-light

thanks


#2

You ordered it yet?


#3

Hi,

I didn’t ordered.


#4

Its underway, i will let you know.


#5

Yes, Yeelight ceiling light is compatible with HA with yeelight component. But you have to set up manually. No auto-discovery.


#6

I have this one - https://www.gearbest.com/flush-ceiling-lights/pp_683848.html, and in my opinion it isn`t working if i add manually a IP to the “yeelight” platform.


#7

Did you received the Ceiling LED?


#8

Nope, not yet. keep you posted


#9

That’s interesting. Based on data, this model (Children Version) is exactly the same with original ceiling light, which is compatible with HA. Young version is a little bit different with original one and this one because it has fixed color temperature.


#10

In my log i see this error:

2017-11-07 17:08:28 INFO (MainThread) [homeassistant.components.light] Setting up light.yeelight
2017-11-07 17:08:28 ERROR (MainThread) [homeassistant.components.light] Error while setting up platform yeelight
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 170, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=self.hass.loop)
File “/usr/lib/python3.6/asyncio/tasks.py”, line 352, in wait_for
return fut.result()
File “/usr/lib/python3.6/asyncio/futures.py”, line 244, in result
raise self._exception
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/light/yeelight.py”, line 136, in setup_platform
_LOGGER.debug(“Adding configured %s”, device_config[CONF_NAME])
KeyError: 'name’
2017-11-07 17:08:32 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_registered[L]: domain=light, service=turn_on>
2017-11-07 17:08:32 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_registered[L]: domain=light, service=turn_off>
2017-11-07 17:08:32 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_registered[L]: domain=light, service=toggle>
2017-11-07 17:08:32 INFO (MainThread) [homeassistant.setup] Setup of domain light took 218.1 seconds.
2017-11-07 17:08:32 INFO (MainThread) [homeassistant.core] Bus:Handling <Event component_loaded[L]: component=light>

My light.yaml:

- platform: yeelight
  devices:
    192.168.1.12:
      transition: 1000
      use_music_mode: True
      save_on_change: False
    192.168.1.11:
      transition: 1000
      use_music_mode: True
      save_on_change: False
    192.168.1.43:
      name: Test
      transition: 1000
      use_music_mode: True
      save_on_change: False

The *.1.12 and *.1.11 works great - one is a RGB Yeelight and other is white. The *.1.43 is a ceiling light and i can`t see on my HA.


#11

Did you enable the developer mode of the ceiling light?


#12

Yes, like always. Like i said 2 yeelight bulbs ar working good but not the ceiling light.
Maybe some DEBUG or sth lik this but how?


#13

It’s exactly this device? https://de.gearbest.com/ceiling-lights/pp_596249.html

Are you sure? There are some more lights around called “ceiling”.


#14

@syssi, no it`s this one https://www.gearbest.com/flush-ceiling-lights/pp_683848.html i have mentioned before, the children version.


#15

Hi, I have the same issue where I can’t control the ceiling light although it’s the only yeelight device I have so I can’t say for sure I’ve got the config right. It’s recognised by adding to config but uncontrollable (comes up unavailable). How were you able to enable developer mode? I have enabled LAN on the Mi Home App but the Yeelight app doesn’t have any setting that I can see to enable developer mode? Perhaps between us we can get them working!


#16

The developer mode = LAN mode in the Yeelight app. Are you sure you have enabled LAN mode in Mi Home, the option to enable LAN mode is only in Yeelight app. It`s strange that you see the light in HA, in my setup the light is not available in HA, any sign in logs or anywhere.
Can you show your config?
My firmware of Ceiling Light is 1.4.8_173.


#17

Hi, yep definitely have LAN mode enabled through the app and entered the key in the config as below:
xiaomi_aqara:
discovery_retry: 5
gateways:
- key: xxxxxxxxxx
Which works for the gateway and the door/window sensor but not the ceiling light.

Have this for the Yeelight ceiling fitting in the config:
light:

  • platform: yeelight
    devices:
    192.168.1.26:
    name: Overhead Kitchen
    save_on_change: true

I’ve commented it out as it only added the “light” to the front end but with no control. I think I need to be able to add a key, similar to the Xiaomi but can’t find out how to get it? I have checked again and under the device in the app it definitely shows Network Communication in the Network Info in addition to the LAN mode on the gateway

My firmware versions shows: 1.4.8_173 same as you


#18

And you have the same ceiling light as mine - https://www.gearbest.com/flush-ceiling-lights/pp_683848.html ?
In the component page of HA this light dosn`t have to add a key like a Geatway, only IP in the yeelight platform. We must wait for @syssi to check this issue.


#19

Actually, mine is slightly different: https://www.gearbest.com/ceiling-lights/pp_596249.html. I have the original which is supposed to work and which @syssi refers to!


#20

Mine works as a charm!

totally happy with it, i will put 6 in my house.