Yeelight RGB 1st gen - automations not selecting proper color temp / brightness

Hello everyone. I’ve been trying for a few hours to fix this issue but I’m not sure this isn’t a bug.

I’m running Hass.io with 2 yeelight RGB 1st gen (YLDP02YL) that worked perfectly on Mi Home. The same issue is experienced in both of them, so it doesn’t seem to be a defective unit.

The plan is simple: I want them to be on MAX BRIGHT and on COLDEST TEMPERATURE (= more “blue”)

This can easily be selected from the slider, selecting White, Max Brightness, Lowest Color Temp:

It translates into this state

with this light result (terrible pic)

And I automate it as follows:

{
  "brightness": 255,
  "entity_id": "light.yeelight_rgb_7811dc6818b5",
  "rgb_color": [
    255,
    254,
    250
  ],
  "transition": "2"
}

However, after running the automation, the brightness and color temp are nowhere as wanted, despite showing in the slider as MAX BRIGHTNESS and LOWEST COLOR TEMP (the sliders would be in the same position as the first picture, but it won’t be real)

The status after automation is :

And as you can see, the light is nowhere as similar to the chosen one:

What’s failing? Is there a problem with the yeelight v1 integration or am I just missing something?

Thanks in advance

How are you sending the data to the light? (ie: in your automation)

I have the below service call as part of an automation action which works:

- service: light.turn_on
  data:
    entity_id: light.ensuite_light
    brightness: 255
    rgb_color: [255,255,255]

Very similar to that, and I tried using 255 as well with the same results, the lights are always “half-bright, half-cold” when using automation"

I recorded a video to show you the process…

  1. I run automation to put it into “cinema mode” in blue (for example, it doesn’t really matter)

  2. Then I run the automation and the brightness/color temp doesn’t get to the desired effect

  3. However, as you can see from the sliders, it appears that “HA” thinks it got the correct setting

  4. I move the slider back and forth and magically it does get the correct setting…

This is driving me crazy

Any hints? Thanks

Having the same issue here. Yeelight controls fine except when running it from automations / scenes. It has the exact same behaviour as yours… Brightness levels are way off

Have you made any progress?

Since upgrading some of my Yeelights to the latest firmware (.something 76) I have had major problems with getting them to turn on to the correct colour and brightness. Not sure what the fix would be other than waiting for another firmware update and hoping for the best.

I haven’t updated mine for a long time, thanks for the heads up. I tend to leave most stuff alone if it works with HA. I’m always afraid a firmware update will break it.

I’m the same. I hadn’t updated them in 2 years and only did it hoping to fix a transition issue… turned out to be a fail

Thanks for the heads up on the update part.

i discovered that Node-red actually does set the correct brightness and color / temp!

What i have done is this:
Created some scenes in scenes.yaml

- name: Netflix
  entities:
    light.hal: true
- name: TL licht
  entities:
    light.hal: true
- name: Warmte
  entities:
    light.hal: true

This way i can make a Glance in Lovelace showing the scenes.

Now the node-red part:
when a scene is triggered, i use node red to set the yeelights to the state i want them in.

This maybe a little devious but it works fine with no delays.

i think someone needs to revise the yeelight integration of HA.