Yellow No USB Device Detected

Ok, this one is killing me. I have 2 USB devices that I am trying to use, the Coral USB and a 433 radio. No matter configuration I have tried no USB device is detected on the USB A ports. I have tried both devices with and without a powered USB hub and a 10 ft high speed USB C cable.

Has anyone had this issue or know of any troubleshooting steps?

Which version of USB do those devices match USB2 or USB3 or USB1?

Or more info since the Coral USB is an accelerator for ML (Machine Learning) and from having to dig deep for info it is a USB 3.0 type C interface/cable.
Did you install the device software on the computer? Maybe it needs that in order to recognize the accelerator.

Found the getting started sheet. Looks like you do need to install the software first.

What is the 433 Radio make/model?
Same sort of question, Did you install the device software on the computer? Maybe it needs that in order to recognize the radio.

There should be no extra software needed for the coral.

What does lsusb say?. What does dmesg say?

Yeah, I’m sorry all. I should have included more information.

I am attempting to use the Coral via USB with Frigate. Frigate is showing that no TPU is being detected. The Coral is USB 3.0.
The 433 recevier is USB 2.0 and I am using the the rtl_433 add on, which also states that it cannot find the device. I used this same device on other hardware and it worked fine.

I used these USB ports on the Yellow to install the OS and the Zooz ZWave stick before I move to the module.

I will grab the exact model of the 433 receiver and also the status of lsusb and dmesg in a few hours and report back.


So I have a Nooelec RTL2832U for the 433 adapter.
Not sure where to go for the lsusb and dmesg information.

lsusb - It is command line command to list information on the usb stuff (buss, ports, etc)
dmesg - It is a command line command to look at information in a buffer called ring, most likely to see what is going on with the usb (error messages, error codes, etc)

Thank you.

My output:
Bus 001 Device 001: ID 1d6b:0002
dmesg | grep usb:

[    0.170731] usbcore: registered new interface driver usbfs
[    0.170806] usbcore: registered new interface driver hub
[    0.170884] usbcore: registered new device driver usb
[    0.171228] usb_phy_generic phy: supply vcc not found, using dummy regulator
[    0.171449] usb_phy_generic phy: dummy supplies not allowed for exclusive requests
[    1.268260] usbcore: registered new interface driver uas
[    1.268334] usbcore: registered new interface driver usb-storage
[    1.268460] usbcore: registered new interface driver usbserial_generic
[    1.268509] usbserial: USB Serial support registered for generic
[    1.277797] usbcore: registered new interface driver usbhid
[    1.277808] usbhid: USB HID core driver
[    5.787345] dwc2 fe980000.usb: supply vusb_d not found, using dummy regulator
[    5.838114] dwc2 fe980000.usb: supply vusb_a not found, using dummy regulator
[    6.056369] dwc2 fe980000.usb: EPs: 8, dedicated fifos, 4080 entries in SPRAM
[    6.068084] dwc2 fe980000.usb: DWC OTG Controller
[    6.080577] dwc2 fe980000.usb: new USB bus registered, assigned bus number 1
[    6.092349] dwc2 fe980000.usb: irq 19, io mem 0xfe980000
[    6.101960] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.15
[    6.122966] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    6.138388] usb usb1: Product: DWC OTG Controller
[    6.151599] usb usb1: Manufacturer: Linux 5.15.84-v8 dwc2_hsotg
[    6.177727] usb usb1: SerialNumber: fe980000.usb

Okay the usb is not powered, but I see drivers for storage, serial-generic, uas is usb scsi and usbhid is the usb human interface device (mouse, keyboard, etc)

usb generic would be used to see and add a usb hub device.

So now what, check your usb devices-, do they need power to operate? If they do use a plug in powered usb that has a power brick, then try your devices. If they still do not function try a different powered hub since it may not put out enough current/wattage for those devices. I have had issues with hubs not working on usb ports, it was the hub being bad.

I know the Coral is power hungry so I got a Sabrent powered USB 3.0 hub as I know others have used this hub to get it working. I had another power USB 2.0 hub lying around and that one didn’t have it work either.