Yet another HomeKit “no response” problem

I don’t know when this started happening, but it was within the last year. All of my devices show up with “no response”. I’ve removed the “home” from my iPad and started again, adding the bridge. But same result.

I’ve seen mention of an HACS integration for HomeKit, but I can’t find it. Does that still exist? I’m still using the homekit: in configuration.

Same here. I updated to 2022.6.5 yesterday and HomeKit stopped working.

A downgrade and restore from backup did not do anything

Any solution found yet? I don’t use HK for much but noticed in the past week my garage doors were not responding from Apple Watch. I checked the HK app and everything is “no response”.

Solved for me!
I am using UniFi network hardware and just resolved by turning OFF IGMP Snooping and turning ON “Multicast Enhancement” (IGMPv3) in the Wifi network settings.

My Apple Home hub had switched from my wired Apple TV to my wireless HomePod Mini and the HomePod didn’t like the way my UniFi APs were handling multicast traffic.

1 Like


Thanks! I’m also on UniFi hardware, I’ve had both IGMP snooping and multicast enhancement turned on for a long time. I don’t have any Homepod products but do have quite a few Apple TVs, so I just disabled all the wireless ones and only let the wired units be HK hubs. Seems to be working now… thanks again!

To be clear, I have IGMP Snooping OFF and Multicast Enhancement ON which seems to be working with either wired or wireless HK hubs.

There’s another thread that resolved by turning off multicast Enhancement… :face_with_raised_eyebrow:

Yep understood. I think I have the IGMP snooping on for my Sonos speakers (it’s a vague recollection) so that’s why I took the different approach.

This has been a constant “it works … it doesn’t work … it works” thorn in my side for months for any wifi Apple devices (Home Assistant is wired, and my wired Apple devices have been fine). Extra weird because the HomeKit camera devices I run through Home Assistant have always worked fine even when things like my switches/locks are “unavailable.”

Yours is the first comment about Multicast Enhancement (IGMPv3) and though it’s buried a bit deeper in the new UI, my wifi-device problems were instantly fixed once I found it and turned it on. IGMP Snooping and Multicast DNS are on, but don’t seem to make a difference for my HomeKit setup.

Anyway, just chiming in here to say thank you!

1 Like

Glad I could help!
My setup has been solid ever since I turned on the Multicast Enhancement setting.

1 Like

I managed to fix all of the broadcast issues including this one by simply moving to Linux docker container installation.

The problem is that Windows/MacOS docker doesn’t really support --net=host mode which is meant to use host’s (machine’s) network - all multicast traffic is broken in this case.