Yet another Samba share problem - Solved

Hi all

I have read MANY threads on this tyopic and tried all of them.

I am running homeassistant on a raspberry pi using 2022.3.4

I have been using the system for several years and have lots of devices and integrations.

Some time back Samba share stopped letting me connect. Still fails.

I have turned on the file and print sharing, added the windows components, etc, etc.

I can ping \ and it works
I can ping homeassistant and it resolves to my HA IP address

It shows all other network devices via my network browsing but does NOT show HOMEASSISTANT
Nor will it let me access it by IP address or by mapping a drive.

In every attempt, it is telling me that the problem is:
The device (homeassistant) is not set up to accept connectioins on the port “The file and printer sharing (SMB)”

I DO havbe File and Print sharing turned on.

OIt seems that it is HA, not windows that is blocking it.

When I start Samba, the log shows that it starts without error

Any suggestions would be greatly appreciated.

Someone reported today that disabling wifi on the pi fixed it for them.

My Pi is connected by cable. How do I disable the wifi?
If I unplug the ethernet cable, I can no longer access the pi so maybe wifi is already disabled?
But my computer is on wifi rather than ethernet cable.

Supervisor / System / Host box, then the IP Address CHANGE link then expand IPv4

You should see Wifi and ethernet options (I have no wifi adaptor in my hardware):

Thankls for the tip.
I learned something new. :slight_smile:
But for some reason, it will not le me make any changes.
'I am logged on as the administrator and I can do most other things.

It DOES let me change the ETH0 settings. I tried turning off IP6.
But it didn’t change anything.

Thiis is the error that network diagnostics always returns.

And for those still followinmg, I DO have SMB 1.0 Client enabled

And my computer is named with workgroup = WORKGROUP
And I’ve tried various username and passwords in Samba. I tried a non exiosting one, and I tried my local user and password on windows, and I tried my HA username and password.

Hmmmm. Just thinking about whjat is different.
I used to have a single 2.4 and 5.0 MHz Wifi accesspoint.
I then purchased a new Mesh Suiper Wifi and it has a single Wifi 6 SSID that claims to operate on both 2.45 and 5.0.
My Pi says its connected to the Superwifi. But maybe it cannot use it. And it won’t let me change it to the old 2.4 MHz that I left running because none of my wifi switches or devices could access the new wifi.
Maybe that is the root cause of my problems. :frowning:

Its nearly 1:00qam so I’m giving up.
I’ll try turning off my new wifi and turn the old one back on tomorrow.

For what its worth, this was MY problem and solution. It may or may not help anyone else.

I had replaced my old Wifi that had seperate 2.4 MHz and 5.0MHz connections with a new Mesh Wifi that broadcast a single SSID that is Wifi 6 and claims to support both 2.4 and 5.0 on the single SSID.
I initially named the new wifi with the same SSID as my old 2.5 MHz so that all of my 2.4 HA devices would work. Theye did NOT. I couldn’t connect.

So I renamed the new SSID with the same name as the old 5.0 MHz and I turned my old 2.4 MHz wifi back on.

Everything worked for quite some time.
Then cooincidentally with my upgrade to HA 2022.3.2, it started missbehaving.

All of my ESP Home devices displayed as Offline. But they all kept working.
And I could not connect to my HA Folders using Samba.

Following a GREAT tip from @Tom_I, I looked at the Wifi connection on the Pi. It was pointing to my new 5.0 MHz wifi connection and could not access it. If I unplugged the cable, it was no longer accessible.

It would not let me CHANGE the Wifi but it DID let me Disable it.
After that, my ESP Home devices came back on-line and I could access the Sambe folders.

I had followed LOTS of instructions to change all sorts of things. But I shut that laptop down and I’m accessing it all on my standard machine with none of it enabled.
I’m SURE that stuff is all relevant for other issues but mine was just that pesky Mesh Wifi.

Hope this helps someone at some time.