Yolink Integration 'almost' Broken by 2024.4 (weird)?

I just upgraded from 2024.3.3 to 2024.4 and the Yolink Integration can not load anymore. I rolled back and all is well again. Anyone run into this same issue? Probably related to the MQTT change?

I was going to delete my post but thought this mmightg be useful to someone some day:


I tried again and had to wait about 30 minutes for the reload to complete (the error message was immediate but I had to go to a meeting but happened to see about 30 minutes latrer some the “unavailable” sensors became available one at a time over the course of 15 minutes or so)… - the red reload error in the HA UI for this integration was showing this popup message (only if you hold your mouse over the highlighted error message):

(‘010301’ Access denied due to limits reached, please retry later.')

I did a search and this is returned from the Yolink API. It is possible they were having a server issue - not sure. I have 66 Yolink devices by the way.

I tried the reload again later and there was no issue - it reloaded quickly and successfully. I believe Matrix2 (the developer) told me there was a limit to the number of requests that can be made of their servers at the same time by any one connection and that was 100 simultaneous requests.

Who knows.

I can verify this was fixed in core-2024.4.2