Your computer is not allowed. (Login issue after adding auth_providers section)

I’m no longer able to login to the web interface from a PC on the local network to my Hassio VM after adding (& deleting auth_providers section).

"You're about to give http://homeassistant:8123/ access to your Home Assistant instance.

Logging in with Trusted Networks.
Login aborted:
Your computer is not allowed.


Running Hassio in a VM, everything was working fine until I noticed some MQTT errors regarding an unrecognized client IP. Turns out it was just connection tests coming from the docker container, not an actual issue. While looking into this issue, a post recommended adding that IP to the trusted_networks section, and I rebooted Hassio. Previously I had no auth_providers: section under Since this point, all I get is the error listed above, and I’m unable to login to the web interface, (I’m logging into ssh to edit config/configuration.yaml then rebooting)

I’ve added my workstation subnet, rebooted. I removed the entire auth_providers: section and rebooted, the same issue. I’ve tried using incognito mode, logging in from another PC, always the same issue.
I can revert to a previous backup, but I’m trying to avoid that.

my current config:


  OS Version:               Home Assistant OS 7.2
  Home Assistant Core:      2022.2.3

Any suggestions?

I should add, clicking “Start Over” doesn’t seem to do or change anything, I never get the option to log in.

The fix for me:

I was finally able to resolve this, even though my previous config didn’t have an auth_providers or trusted_networks section, adding the following using SSH / VIM , then having proxmox shutdown and restart the VM I’m now able to login without any issues.

  customize: !include customize.yaml
    - type: homeassistant
    - type: trusted_networks

I have similar issues with trusted_networks auth provider and it did not want to work no matter how I tried.
Then, I found a crucial setting that clashed with this on the official page.
I am using NGINX proxy to reach my HA from outside of the network via an encrypted channel.
It turned out that once you set up an IP address for trusted_proxies it cannot be used in the trusted_networks too. They will simply not work.

So, I added my localhost IP to the trusted proxy and removed everything else, while adding the IP address of the machine on my local network. My issue was that I wanted to have the same device to be allowed to bypass authentication.
I am using raspberry pi for HA and it has a touchscreen connected to it. So I choose 192.168.0.X/32 for trusted_networks which is the IP address of the raspberry pi itself.

I hope this helps if you face the same issue.

1 Like