"Your connection is not private" warning. DuckDNS, Let's encrypt


my HASSIO server is running since a couple of months perfectly with Let’s Encrypt and DuckDNS. However, since the beginning I get this warning that my connection is not private ssl error. With time it started to bother me so is there a way to get rid of the message permatily? Clicking on advanced and verify that I want to connect is really annoying.

Everything else is working perfect. I can access Hassio from outside over the duckdns address just fine. Time and Date settings are correct on the Hassio Server.

Kind regards

It doesn’t sound like you set up Let’s Encrypt correctly. This makes you vulnerable.

Did you generate SSL keys and add the location of the keys to your configuration.yaml file?

Solved it. The problem was due to my DNS settings and my Ubuntu host which needs to have the Google DNS in the resolv.conf file.