YouTube on Roku: “Something went wrong”

When using the Roku media player entity in HA to open YouTube, it launches the app fine, but, instead of displaying the YouTube home menu, YouTube says “Something went wrong”.

Netflix, for example, launches as expected.

Any ideas please?

Could you show a picture?

I have this issue as well! I first start the TV with Logitech harmony, then wait 30 seconds and switch to YouTube channel and get this message. Happens on both an “express” roku, and a TCL Roku embedded OS. Clicking back and channel loads fine.

FWIW - I found a workaround to this. During the automation, I wait 15 seconds then send the left and select remote commands to start with youtube standard screen.

service: remote.send_command
 entity_id: remote.tcl_roku_office_1
   - left
   - select

Yes, good thinking. I’ve now done a similar thing, but just pressing the “back” button, and I find that 7 seconds is sufficient.

Roku maintainer here. This may have been an issue with how we launched apps improperly in previous HA versions. Have you tried 2022.2?

1 Like

Yes, I just tried it and it seems to work fine now. Thanks!

1 Like