YSRSAI ZB-CL01 RGBW controller Unexpected Behaviour

I have recently moved to Home Assistant from Domoticz and am very impressed so far. I am finding things very different in Home Assistant and am still finding my feet so please forgive me if I am missing something obvious with my problem, I have searched the forums, docs and the wider web but haven’t found anything helpful.

I am running Home Assistant on my server using the official docker image. I am attempting to control YSRSAI ZB-CL01 Zigbee RGBW controller through a Hue Hub V1. The controller is added via the Hue app and is discovered by Home Assistant when adding the Hue Integration.

The device seems to be added correctly and controls for dimming a colour wheel and warm/cool white are displayed correctly.

My problem is that I cannot change the colour of the LED strip, dim etc. unless I set the desired colour etc. and then switch the light off and then on again. Is this the expected behaviour?

I feel like I’m missing something really obvious here but after playing with it for a couple of days I am at a loss, any help would be gratefully received.

Many Thanks

Did you ever figure this out? I just bought a few bulbs with this controller (only option really because not many options when it comes to mr16 lights) and added them through my Hue Hub V2 and having the same issue.

Mine are on firmware 1.09 and the page mentions ewelink, I got a sonoff zigbee hub coming so will try it with that and also see if I can update the firmware but maybe you found something else out?

Hello, same problem at home :frowning:
I can just change color with hue app.

Ever figured this out? Same here… All well with the Hue app, but with Home Assistant it has strange behavior of not setting the color right or switching to a random color after executing a script.

I’m having a different issue with these and eWeLight controllers, but had the same desire to update the firmware. I have many bulbs and USB controllers all ZB-CL01s made by YSRSAI and eWeLight.

I went to Aliexpress and bought a Tuya Hub and a Sonoff ZBBridge to try updating the firmware on the ZB-CL01s. The short answer is no. You cannot update these controllers using a Sonoff or Tuya bridge.

Here’s my longer answer:

My working theory is that the ZB-CL01 is a generic LED module made by a Chinese company called eWeLight which is then used by other companies like YSRSAI, Liokke, CMARS, etc. to make their own LED bulbs that you see on Amazon and Aliexpress.

Like Gledopto, eWeLight and YSRSAI have their firmware factory installed and are not updatable in the wild (at this time).

There’s an assumption that eWeLight and eWeLink are the same company, and I’m not sure that’s the case. Sure they’re similar sounding but that means nothing.

If you search AliExpress for eWeLight, you’ll come across a seller who is offering various zigbee modules for about $3-5. In particular, the ZB-CL01 is actually a ZYZB007. It might be worth someone contacting eWeLight on Aliexpress and asking if they have the OTA file for firmware 1.013 or something newer. (I did see another post saying that the 1.0.13 firmware doesn’t fix OP’s issue.) Other Zigbee controllers/modules sold on AliExpress often have links to flashable firmware and other OTA files, I went digging and didn’t find anything helpful on my own.

For me the 1.013 firmware fixes a ZHA colorloop issue I’ve been having, where it just freezes at a pale green. So I’m really interested in finding a way to update my bulbs and controllers.

Hopefully this Information helps, but I hope it at least saves you from buying useless hubs.

1 Like

I have some of the ZB-CL01 lights. They worked fine up to Home Assistant core-2021.4.6. Mine are connected through a Sonoff bridge flashed with tasmota.

In my case the symptom is that the lights respond to every command except they cannot be turned off. I can change the brightness, color, color temp, etc but I cannot turn them off. I can even turn them ON just fine, but not off.

And again, in core-2021.4.6 they worked properly… which is why I’m still stuck on that version.

I had the same problem but I fixed it by creating an automation. When I turn off the light using the script, it turns off as expected.

- id: '1636393203377'
  alias: LEDstrip muur uit
  description: ''
  - platform: state
    entity_id: light.ledstrip_muur
    to: 'off'
  condition: []
  - service: light.turn_off
      entity_id: light.ledstrip_muur
  mode: single

I use node-red rather than the built-in automation so that wouldn’t work for me. I ended up buying new (and better) bulbs.

Can you please share the 1.0.13 firmware?
I have a few led stripes named YSR-MINI-01 from YSRSAI and the come up with modelid “ZB-CL01”.


I don’t have any firmware files. I have nothing to share.
My post was trying to communicate that you cannot upgrade these devices.

Devices with the 1.0.13 firmware (applied at the factory) appear to work okay. There is no way* to extract the firmware from one LED controller to put on another.

*Someone with a background in electrical engineering and computer programming might be able to dump the firmware from the controller and reverse engineer it, but that is a lot of very specialized and time consuming work over a $9 LED controller. Nobody would waste their time on this.

tl;dr: Just invest in better hardware, it’s not worth the hassle. You can’t upgrade them.

Got you.
Thanks for clearing things up.
Will stick with the “issues” because otherwise they are working.

So that I don’t open a new thread…

Has anyone figured out how to make an external converter for Z2M to get just brightness adjustment for this device?
Because Z2M displays them as RGBCCT, meaning you can select the white color, which you can’t.

I’m trying to make a custom controller to use “color_temp” instead of “color_xy” when color is set to 255 255 255 but with no luck.