Z stick 5 installation help please

Hi, I am attempting to install a Z stick 5 using this guide Setup Home Assistant with Z-Stick Gen5+ : Aeotec Help Desk
The installation is with the Z-Wave JS UI add-on by Daniel Lando.
I have reset the stick several times
In Windows the Z stick shows as USB serial device (I wondered if it should show as a Z stick and drivers are missing?

The Z Stick does not show up during installation and after populating the port fields randomly and saving I have the error
023-07-12T09:32:42.546Z DRIVER Failed to open the serial port: Error: No such file or directory, cannot open
I have tried all the available USB ports

Any help would be appreciated

Paul, How are you running HA? (via a virtual machine? on a separate machine?) If you check Settings->System->Hardware->All Hardware it should show you which tty the devices are on. That would be the first thing I would check.


David, thanks for the fast advice, I’m an absolute novice, but a keen one, so please bear with me :smile: I am on a VM on a laptop, and I will look at your suggestion tonight.
Much appreciated

The Aeotec v5 has a hardware error which breaks specific USB ports such as the RPi4.

Basically, Aeotec appear to have screwed up and applied 5V, not 3V3 to the D+ pin. The fix requires soldering (works fine for me with both a RPi4 and a Yellow), or a dumb USB hub.

If this helps, :heart: this post!


Thank you, James,
So the best solution looks like I should find a new brand of Z wave stick.


The pain is Aeotec didn’t apparently admit the issue, but later released a new product with a “fixed” USB interface. Some folk suspect they just couldn’t afford to replace the devices without going :boom: financially.

On the other hand, their hardware is otherwise pretty good and usually they have been better than others (looking at Fibaro and their complete refusal to release firmware updates - I have to have a 2nd hand Home Centre Lite just for maintenance).

Later coordinators support security (e.g. the 7xx series) and after some early firmware issues, they work.

Personally, I’d try a cheap dumb USB hub first - moving the radio away from a USB3.0 port is good to avoid RF noise anyway, so it isn’t a great loss. Have a look at the linked posts…

1 Like

Get a USB hub, I have been using this one on 3 HASS systems works great.

Belkin 4-Port USB Hub - Powered Desktop USB Docking Station - USB Adapter supports USB A, USB 2.0 and USB 1.1 - USB Charging Hub - USB

1 Like

Just a thought. I’m on ha using a laptop with a VM, is this likely to affect me, or just pi devices?

Depends on the USB hardware - only way to know is to test.

1 Like

The hub is only required for the RPi4. It doesn’t affect other platforms.

1 Like

Did you enable USB pass-through in the VM configuration to expose the device to the guest?

1 Like

Thank you all so far :slightly_smiling_face:

I have “enable USB connector” checked, is that the same?
In my laptop device manager, I see Com port 3 has a UBZ device attached.
VM has Sigma designs which I assume is my Z stick as it is Zwave.
tty information from HA is below (I am not advanced enough yet to decipher this)
Thanks for sticking with me.

Device path:/dev/ttyS0
tty S0
DEVNAME: /dev/ttyS0 DEVPATH: /devices/platform/serial8250/tty/ttyS0 MAJOR: ‘4’ MINOR: ‘64’ SUBSYSTEM: tty TAGS: ‘:systemd:’ USEC_INITIALIZED: ‘6149413’

Device path:/dev/ttyS1
DEVNAME: /dev/ttyS1 DEVPATH: /devices/platform/serial8250/tty/ttyS1 MAJOR: ‘4’ MINOR: ‘65’ SUBSYSTEM: tty TAGS: ‘:systemd:’ USEC_INITIALIZED: ‘6131933’

tty S2
Device path:/dev/ttyS2
DEVNAME: /dev/ttyS2 DEVPATH: /devices/platform/serial8250/tty/ttyS2 MAJOR: ‘4’ MINOR: ‘66’ SUBSYSTEM: tty TAGS: ‘:systemd:’ USEC_INITIALIZED: ‘6134247’

Device path:/dev/ttyS3
DEVNAME: /dev/ttyS3 DEVPATH: /devices/platform/serial8250/tty/ttyS3 MAJOR: ‘4’ MINOR: ‘67’ SUBSYSTEM: tty TAGS: ‘:systemd:’ USEC_INITIALIZED: ‘6136554’

The evidence is the Rpi4 is complaint the USB spec, but the v5 applies 5V to D+ when the pull-up should be to 3V3.

The hardware issue may impact any platform - it’s just well known on the RPi4 as it is a common small server.

Bodge wires to move the Vcc from 5V to 3V3 fixed my hardware, and many others.

1 Like

Doesn’t look like it, you’ll have to say which hypervisor you’re using.

These are serial port devices, none are USB serial devices.

1 Like

Thanks, I’m not confident in my soldering abilities on such small devices :slightly_smiling_face:

Thanks, its Oracle VM virtual box which I have googled as a type 2 hypervisor

Just a small update, I did more research and interrogating settings on the VM.
I created a filter for the Z stick and restarted HA and the VM.
When HA booted I had a pop-up asking if I wished to set up ttyACM0 from the Z wave integration. (I thought I had previously uninstalled this, as I read that you can’t have both Z wave and Z wave JS UI running at the same time.
However, now following the original guide again I no longer get the original error and JS UI reports my configuration as successful.
The z stick still doesn’t show in JS UI control panel and I am getting “Error while calling get ProvisioningEntries: Z-Wave client not connected” But I actually feel like I am getting somewhere.

Can you share your hardware platform? I was not aware this affected other hardware besides RPi4.

Nope, you can’t have both add-ons installed and running with the same USB stick. I would suggest uninstalling the integration and Z-Wave JS add-on, and install the Z-Wave JS UI add-on instead, following the add-on documentation.

1 Like

Just in the interest of other community members facing the same issues as this newbie.
I spent a lot of time last night trying to bottom the reasons that I couldn’t get Zwave JS UI working.
I installed the original Z wave integration and it worked like a charm, it found my Z stick and I could start installing my test devices. It immediately found a TKB plug and a minimote.
The good thing is, now I know that the Z stick works, that the VM sees it and that HA sees it in one integration.
I am aware that JS UI is the way forwards and I will revisit it once I have actually had a play with HA, learning Zigbee, automations and dashboards.
Thank you all for your help and suggestions