Z-STICK gen5 and reboot

Hello,every time i reboot hassio(last version) my usb zwave stick become unreachable from the ui?
If i unplug the rasp3 power and plug it back the stick works again till next restart from the ui.

I have added this line into my config:

zwave:
  usb_path: /dev/ttyACM0

I’m receiving this code:

2018-02-23 13:15:07 ERROR (MainThread) [homeassistant.setup] Error during setup of component zwave
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/openzwave/option.py", line 78, in __init__
    raise ZWaveException(u"Can't find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: "Zwave Generic Exception : Can't find device /dev/ttyACM0 : ['NoneType: None\\n']"

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/setup.py", line 148, in _async_setup_component
    component.setup, hass, processed_config)
  File "/usr/lib/python3.6/asyncio/futures.py", line 332, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.6/asyncio/tasks.py", line 250, in _wakeup
    future.result()
  File "/usr/lib/python3.6/asyncio/futures.py", line 245, in result
    raise self._exception
  File "/usr/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/zwave/__init__.py", line 275, in setup
    config_path=config[DOMAIN].get(CONF_CONFIG_PATH))
  File "/usr/lib/python3.6/site-packages/openzwave/option.py", line 81, in __init__
    raise ZWaveException(u"Error when retrieving device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: 'Zwave Generic Exception : Error when retrieving device /dev/ttyACM0 : [\'Traceback (most recent call last):\\n\', \'  File "/usr/lib/python3.6/site-packages/openzwave/option.py", line 78, in __init__\\n    raise ZWaveException(u"Can\\\'t find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))\\n\', \'openzwave.object.ZWaveException: "Zwave Generic Exception : Can\\\'t find device /dev/ttyACM0 : [\\\'NoneType: None\\\\\\\\n\\\']"\\n\']'

I have two zwave entities, is it normal?

I thought it will easy to configure from the video i have seen, with a one button pairing mode. I bought a fibaro motion sensor and i can’t figured how to pair them thougether.

Any help would be awsome.

Thanks

That’s not normal.
Do you have any other USB devices connected ?
Is there any clues in your OZW_Log.txt file ?

My rpi was unable to find the z-stick after I changed USB ports.
I plugged it back into the port I set it up on and everything was fine

Hello, i have unpluged the rasp3 power and now i have just the ‘zwave.aeotec_zw090_zstick_gen5_eu’ entitie.

Thanks.

I solved this by using udev rules.

add this to the bottom of the file, modifying the symlink part to whatever you want to call your stick:

SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ttyUSB-ZStick-5G"

SUBSYSTEM=="tty", ATTRS{interface}=="HubZ ZigBee Com Port", SYMLINK+="zigbee"

then configure your usb path to that symlink.

I also have a zigbee device so i included it above in case anyone else has one of those too.

Use the instructions here :

Don’t use the button on the z-stick, it just stuffs things up.

Remember to ‘heal network’ then reboot hassio after adding devices.

Once your device is properly added it will probably add more than one entity under the states page.
As an example, a zwave door sensor might show up as binary_sensor.whatever_ you_call_it with the basic ‘on’ or ‘off’ state, and a zwave.whatever_you_call_it with attributes for comms status and battery level etc.

1 Like

Thank you ‘jivesinger’

Happy to help :slight_smile:

Let me know how you get on.

Everything is showing up in the ui, again thank you very much.

However i think the motion detection time-out is 30 sec, is it possible to reduce it?

Thanks

I’m not familiar with fibaro, I have Vision and Aeotec, but…

Try going to Configuration -> ZWave
Select your node
And check for anything under ‘Node Config Options’

I was able to reverse the state indication, and fix some sleeping issues this way

Ok, i will have a look at it.

Thanks.

Ok i have found the option but when i change from 30 to 10 it’s going back to 30 sec.

Any idea how to fix this?

I have the same issue with my window sensors.
The problem is that they go to sleep VERY quickly after sending their info.

Have your new info typed in and ready to go with the mouse on the ‘Set Config Parameter’ button.
Press the Pair / Zwave button on your sensor, and almost instantly press your mouse button.

I was often having to try two or three times before I got the timing right.

1 Like

Ok, i will try this. My sensor needs 3 short press, hope it will not be so hard.

Thanks.

Thanks It’s working perfectly!

Glad to hear it !

It was only a few weeks ago that I set up my zwave sensors so it’s all still pretty fresh in my head :slight_smile:

Cannot get the Figaro FGMS-001 to pair with the Z-Stick. Can I ask for some assistance please?

Fresh Hassbian installation. The first and ONLY thing I am trying to do is get the Z-Stick and the Figaro working.

The Z-Stick is plugged in and I have rebooted (several times this morning already). The device looks to be configured correctly.

I have tried to pair the devices through HASS UI (Config > Z-Wave > Add Node, then pressing 3x on the Figaro’s internal button) and also unplugging the Z-Stick and pressing the physical button.

Same effect = no pairing.

I see data in the OZW_Log.txt, specifically when clicking the “Add Node” action:

2019-04-05 11:10:26.955 Detail, Queuing (Controller) Add Device
2019-04-05 11:10:26.956 Info, Add Device
2019-04-05 11:10:26.956 Detail, contrlr, Queuing (Command) ControllerCommand_AddDevice: 0x01, 0x05, 0x00, 0x4a, 0xc1, 0x0a, 0x7b
2019-04-05 11:10:26.956 Detail, Notification: ControllerCommand - Starting
2019-04-05 11:10:26.957 Detail,
2019-04-05 11:10:26.958 Info, contrlr, Sending (Command) message (Callback ID=0x0a, Expected Reply=0x4a) - ControllerCommand_AddDevice: 0x01, 0x05, 0x00, 0x4a, 0xc1, 0x0a, 0x7b
2019-04-05 11:10:26.961 Detail, contrlr, Received: 0x01, 0x07, 0x00, 0x4a, 0x0a, 0x01, 0x00, 0x00, 0xb9
2019-04-05 11:10:26.961 Detail,
2019-04-05 11:10:26.961 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:
2019-04-05 11:10:26.962 Info, contrlr, ADD_NODE_STATUS_LEARN_READY
2019-04-05 11:10:26.962 Detail, Node001, Expected callbackId was received
2019-04-05 11:10:26.962 Detail, Node001, Expected reply was received
2019-04-05 11:10:26.962 Detail, Node001, Message transaction complete
2019-04-05 11:10:26.962 Detail,
2019-04-05 11:10:26.962 Detail, contrlr, Removing current message
2019-04-05 11:10:26.962 Detail, Notification: ControllerCommand - Waiting
2019-04-05 11:10:26.965 Info, WriteNextMsg Controller nothing to do

If I select the Overview option from the main menu, it shows this, suggesting the device is not on?

the toggle in that card doesn’t do or indicate anything. you can completely remove it if you want. the thing that matters is on the next line where it says the device is “ready”.

I can’t help with the specifics of how to pair a fibaro device since I don’t have any.

After you attempted to pair the device have you looked in either the z wave control panel section of the configuration area or in the dev-states page (or both) to see if any additional z wave devices are showing up?

Thanks @finity

The setup looks good. devices are reporting as “Ready”, blinking lights, etc…

When I click the “Add Node” button, I get some of the lines from log file, and then the log file has no futher entries than the:

Info, WriteNextMsg Controller nothing to do

The Fibaro device does not appear in any part of the HASS interface.

Others are using a different openzwave web interface, I think on port 8888. This doesn’t resolve on my system. I presume this is the native openzwave software, which HASS integrates with? How can I view this interface? Are there additional log files or settings that I can apply?

I haven’t set a Network Key, as I don’t have any “secure devices”. Could this cause this issue?

click on the hamburger menu on top left. click on “Configuration”. Click on “Z-Wave”.

in there should be a drop down with all the z wave nodes listed.

or in the same hamburger menu go to the bottom, second from left and click the <> icon to bring up all your entities and go to the bottom and look for “zwave.xxx” entities.

The only Node is the Z-Stick itself, which I can select.

There are no entities beneath it or other Nodes.