Z-Wave ACK Errors and Total Failure

Over the past couple of days I’ve been getting “zwave_js_server.exceptions.FailedZWaveCommand: Z-Wave error 200: Timeout while waiting for an ACK from the controller (ZW0200)” on a very regular basis, and Z-Wave is really unreliable.

Last night, the HA server went to 100% utilization then rebooted itself (this when I was going to bed and nothing would turn off, Insteon Z-Wave or otherwise). While at 100%, before rebooting itself, I tried to restart the core, nothing happened and then a full hard reset on its own.

I shut down the rPi and pulled the plug then plugged it back in and it wouldn’t even boot. Just a slow yellow flash on ethernet. I took it upstairs and plugged it in, just the rPi and the ethernet and got my network green blinking light again. Took it downstairs, plugged the USB hub back in and back to slow yellow.

So I shut it down entirely, removed the USB hub from the rPi, unplugged the power the hub, started it back up and powered up the hub and things came back. But, looking at the logs as soon as it started, I was getting the “zwave_js_server.exceptions.FailedZWaveCommand: Z-Wave error 200: Timeout while waiting for an ACK from the controller (ZW0200)” again.

So I’m not sure if my Z-Stick (Gen5) is going south or what and if it is if it would cause this kind of catastrophic failure. I went on to Amazon to order a replacement just to be safe and, of course, there are no Gen5, Gen5+ or Gen7 to be found with no anticipated arrival dates. My only option is a Zooz S2, which I know is a good stick, however I don’t think I can migrate my entire network to it meaning I have to completely redo my entire Z-Wave network from scratch. I know on my Gen5 I can use a backup/restore program by Aeotec.

I did as much clean up as I could, I had the stick purge all unknown/failed devices (which actually removed a good one for whatever reason, perhaps it couldn’t ping it at just that time), made sure I applied the update to ZwaveJS that looked like it released yesterday

Does anyone have any insight on this that might help me diagnose this problem? SD failing? Z-Stick failing? I’m not sure what could cause so many issues so quickly. This all occurred in the past two days and there’s been no new devices added to Z-Wave or anything I can think of that has changed.

The only other thing I can do with what I have, that I can think of, would be to back up the stick, factory reset it and restore it. That should be fun.

I’m wondering: if I flash the Gen5 to the latest firmware (1.02), does that wipe out the stick entirely to the point I have to re-pair? If so, does the NVM backup in ZwaveJS essentially restore everything or do I need to use the AeoTec restore utility?

Along those same lines, if I were to restore successfully, would that restore the devices identically so that it becomes plug-and play right back into HA?

I’m trying to get a feel for these things before I do them so I know if I need to order a new stick (of some variety) as an insurance policy. My fear is that I brick the z-stick or go through all of this just to find I have to manually re-pair every device anyway.

I’ve read conflicting reports that the NVM backup/restore in ZwaveJS doesn’t really work if you aren’t on the latest firmware, so perhaps my only recourse is the AeoTec backup utility (which I’m going to do regardless).

I have similar issue:
“ZWaveError: Timeout while waiting for an ACK from the controller (ZW0200)”
Were you able to solve issue?

In the end I replaced my Z-Stick with a new one and the errors cleared up, however I think that updating ZWaveJS also helped since I had a buggy version. I still get that message from time to time but it’s not as constant as it was before.