Z-Wave - Aeotec ZW112 Door/Window Sensor

I just bought a ZW112, applied the latest firmware, and securely joined it to HA. I quickly noticed that the device was not waking up properly, so I checked the OZW logs:

2018-09-10 20:03:02.397 Warning, Node022, Received a Clear Text Message for the CommandClass COMMAND_CLASS_WAKE_UP which is Secured
2018-09-10 20:03:02.397 Warning, Node022,    Dropping Message

HA is (rightly) ignoring the clear-text wake up notification and so will never see the device wake up. This caused quite a few headaches why trying to configure the ZW112 to send Sensor Binary Reports so that it would work with HA. I had to re-include it a number of times before the successful attempt where I managed to slip the command in the initialization process.

This also means that, if HA is restarted, there is no way to fully re-associate the sensor. It’s stuck at Initializing (CacheLoad). Even if I wake it up by holding the button down for three seconds.

I can’t quite believe a product that cost this much money can be so flawed, so I must ask: Am I doing something wrong? I opened a ticket with Aeotec but haven’t heard back you. I’ll post updates here. If anybody else has encountered this, please respond.


Its not uncommon for my zwave PIR devices to be sleeping or in cache load status. But they work flawlessly. Do you get anything in HA if you open or close the sensor?

Hi dap35,

Sleeping is the correct status for battery-powered Z-Wave sensors. Sure, they’ll work while in CacheLoad state, but they can make it through all of the stages and go to sleep again if you wake them up briefly. One reason you might want to do this is to update their configuration. My sensor was reporting status but using the basic command set. I wanted to change it to a sensor binary report, the proper setting for HA. This is where I had a problem. The documentation talks about only two ways to wake it up: 1/Press the action button once to send a wake up notificaiton to the controller or 2/Press and hold the action button for three seconds and, when the button is released, the light will blink for ten minutes to indicate it is awake.

The problem here is that, when the device is included in a Z-Wave network securely, waking it up this way sends the controller a wake up message in clear text. The controller ignores the message because it is not encrypted. As I mentioned, this means the controller can never know when the device is awake and ready to receive configuration (or to complete initialization).

  1. The light keeps blinking the whole 10 minutes when the device goes back to sleep, unless you press the action button

Anyway, I think I finally found a way to do a secure wake-up. I pressed the button twice and held on the second press for three seconds. It accepted its configuration change and has been added properly to HA.

Now that I know I won’t be restarting HA over and over again to fuss with this, I’ll reset my First Alert ZCombo Smoke and Carbon Monoxide Detector so that it goes through the full initialization and reports as sleeping instead of Cache-Load.

1 Like

Good to know. I’m glad you found the answer.

If you are still having trouble, contact Aeotec support and ask for firmware 1.03 . They sent it to me yesterday and it fixed all my issues. Wakeups are now secured, single keypress does a secure wakeup, and for the most part I can associate new sensors with a single wakeup (not 5-6 attempts like before).

…If I buy another. Motion detection is broken (I think I dropped it one time too many), so I’m not using it right now. But it is good to know they are providing updates.