Z wave Button help


I am far into process of migrating away from Wink and am learning Z Wave “stuff” every day. I have a Aeon USB stick, working fairly well with about 30 nodes so far…

I now have a Fibaro button and am surprised I can not do what I want, I get that it really only controls other z wave devices.

Is it possible to use it direct with HA so that I can write automations ( I dont use Node Red…yet, but maybe never)

The only way I can see to use it is to group or associate it with a binary device like a door sensor and use that as a trigger. Is it possible to use more directly? The button presses do not seem to return anything on the sensors I have after inclusion. Is it possible to make a binary_sensor out f 1 of the sensors, although I still need to “see” something in HA from the button press(es) action.

Hope that is clear!

You will need to follow the docs in order to manually enable Central Scenes, which can be used in automations.

ok, do I had dabled with that a bit, do I have to add the code to every node or just the nodes I would want in a scene? Thank you too, btw!!

Only the node that is the button. Make sure you stop HA before editing the file.

1 Like

ok, so after 2 failed attampts I finally got it right…as in I can get the Z wave network up again…but the Fibaro button now only has 2 sensors showing, the other 5 that were there are no longer there, they are greyed out…no zwave.scene or anything under services or events. I’ll try a repair node…?

under node it states (Node:27 Probe)

update: it seems like it is a dead node, can not do anything with it, can not exclude, I have tried resetting the device as per Fibaro instruction, remove battery, heal, refresh node, rebooting a few times, tried inclusion again, nada should I go back a remove the code I pasted in and try again?

uodate again: I worked out the problem, had duplicate code, only needed part of what was there…so i was able to include the button again as a new node but can not remove the corrupt node, can I just go delete the node info from that same xml file?

This is getting ridiculous lol! OK, so I have the button with a new node and the right code pasted in. Still not seeing anything related to scenes, any idea of what i am missing??