Z-Wave Can't Find Zooz Zen30 2.0 Switch

Hi All,

I’m trying to add a Zooz switch to HA and when I put the switch in inclusion mode and Add Device, it’s never found.

I’ve contacted Zooz and one of their recommendations is to exclude it first (even though it hasn’t been added). The directions they send are as follows:

  1. In Home Assistant: open Configuration > Integrations > Z-Wave JS > Configure
  2. Click on Remove Node
  3. Click on Start Exclusion
  4. Tap the lower paddle of the switch 3 times very quickly (the LED indicator will start flashing)
  5. Home Assistant will confirm that the device was removed, and you should now be able to add it to your system

The problem is, I don’t see any Remove Node feature. Am I missing this or does it not exist? I can see where to remove a device once it’s added, but no generic Remove Node feature for devices that haven’t been added.

My HA setup with the stick is about 15 ft from the light switch. I am in test mode of HA for a new house I’m building and only have one other Z-Wave device on the network. It’s within 10 ft of the switch. I’ve moved it within 3 ft and also tried, just to be sure it wasn’t a distance problem.

Other details of my system are as follows:

  • I’m using the Nortec Zwave/Zigbee combo USB stick
    • Device info HUSBZB-1 by Sigma Designs (Former Zensys)
    • Firmware: 4.32
    • Z-Wave InfoDevice ID: 1
  • Z-Wave JS Version: 0.1.61

Home Assistant Core 2022.6.6
Home Assistant Supervisor 2022.05.3
Home Assistant OS 8.2




Settings > Devices and Services > (Scroll down to find the) ZwaveJS Integration: Configure (Button)

Resulting screen: (Middle of the page, under diagnostics)

1 Like

I guarantee that I know less about Z-wave than you. But I found this in “Manage Nodes”:

  1. CLick on “Actions”:

2: Click on “Manage Nodes”:

That’s because you’re using the ZwaveJS2MQTT console - not ZWave JS (Naming matters, yes the owners of JS know the names are confusing)

In that case, you go here:
ZWaveJS2MQTT Dashboard (where you were)
Actions > Manage Nodes (the one your arrow points to) > Nodes manager (the next screen you would have opened) > Exclusion (button)

The first instructions you gave also work with Z-WaveJS2MQTT as you described. Settings → Devices & Services → Integrations tab (default) → click the Configure link inside the Z-Wave block.

1 Like

Thanks guys! My Remove Devices is greyed out. I do have at least one device I should be able to remove though.

I’m using ZWave JS, so I don’t have the Actions I don’t think.

Maybe I need to roll back my version of Zwave and/or reinstall?


Weird. There was a bug but that should be fixed (since 2022.3.0) based on your version list. Z-Wave JS “Remove device” option is disabled · Issue #67936 · home-assistant/core · GitHub - but worth checking maybe, if you have any Provisioned Devices, see Z-Wave JS "Remove device" option is disabled · Issue #67936 · home-assistant/core · GitHub for the specific details.
Other than that, do try a reboot if you haven’t already.
There is one other reasonably easy way to do an Exclude without too much trouble. Assuming you have a Windows PC, shut down your HA instance, remove the USB stick and pop it into your PC. Then download any of the Aeotec firmware updates, which contain a cut-down version of the Silicon Labs software. Once it loads up, go to Categories / Settings / select the appropriate COM port for your USB stick, then go OK then Remove Node up the top.

Thanks for this additional info. Another ZWaveJS update came out today and running it fixed the issue.

1 Like