Z-wave Climate Issue - Missing Thermostat functionality

Tags: #<Tag:0x00007f7c598b33a0>

Hi,

I have two Trane Z-Wave thermostats. They worked fine before somewhere before version 0.97-0.100. Now, I only have partial functionality. And what’s really interesting is that one of the almost has no functionality even though they are identical.


What works:

  • HVAC mode - cool, heat, heat_cool, off
  • I can set the cooling temperature target

What doesn’t work:

  • I cannot change the heat target temperature…at least I cannot find it in HA to change it
  • For my second Trane Z-wave, I can’t change/control anything. It has the same entities as the first, but with and “_2” at the end.

What I’ve tried:

  • Uninstalling/reinstalling zwave integration
  • Uninstalling/reinstalling trane devices from my zwave hub
  • Reverting back to 0.97…everything works as expected
  • Opening an issue on github…nothing and its been about a month

Any help would be much appreciated!

Running Hass.io on docker on RPI 3b+

Do you have a thermostat card setup in your lovelace UI?

Yes, but the problem doesn’t seem to be the card. It seems to be how the zwave climate integration interacts with my Trane thermostat (which used to work btw, but seem to have broken somewhere around HA 0.100). Any ideas?

Climate 1.0 per the blog.

Thanks. It didn’t help, but it did jog my memory. Initially when 0.96 came out I had issue. I submitted a github issue and it was promptly fixed. It worked again in 0.97 with the new updates to the climate platform. But somewhere since then it stop working fully again.

Wondering if you’re missing the xml for the thermostat in your openzwave config.

Could be, how do I tell? I thought the xml file was an output file and not something that I can modify?

You’d have to get into the container and check which ever directory openzwave is installed to.