Z-wave climate mode not working

I recently upgraded to 0.116.4 running in a docker container. My prior version was running on a Pi3 @ vers ~ 0.8 or so. I have a Trane Zwave thermostat (TZEMT524AA21MA) that worked fine on the previous install. HA would expose it as 4 separate entities but now in the latest version HA exposes a sensor and a mode entity. The sensor reports the thermostat temperature correctly, but the mode entity card is unresponsive.

I’m not sure how to fix this, any help appreciated.

I am using TZEMT524AA21MA with 116.4 and now using 117.6.

I have this issue in past but don’t remember exact cause. I think i fix this by remove device from zwave and add again.

Thanks for the reply. I’ve tried excluding and re-enrolling in the z-wave network a few times. I thought maybe Since it would report the temperature correctly but the mode control/temperature settings were grayed out in the UI that maybe it needed to be added as a secure node, but that didn’t seem to work either.

Maybe try exclude then reboot HA and power cycle thermostat then readd to zwave.

Secure note is not necessary

I had a similar issue with the new unit after I purchased it… I ultimately return that unit.

Ultimately though it should be working without issue

I also have this issue after my Z-Wave network failed due to power outage… In this case I just started from scratch rebuilding entire z-wave network by resetting Z-Wave stick and re-pairing all devices