Z-wave Configuration: Manually Add Last Resort?

I am just about to toss in the towel and manually add nodes using the z-sticks button, but I have read the warnings against that method. So I thought I would ask the experts first.

Here is my hardware:

  • Synology NAS
  • Docker
  • AEON Labs ZW090 Z-Stick
  • 3 Z-wave devices (door sensor, dimmer, and switch)

I can see my Z-stick in Z-wave network mgt section, but I cannot add a new node. I have tried to Add Node but I cannot get anything to Add. Below is a recent excerpt of my log. Any suggestions are greatly appreciated.

2019-12-04 01:19:52.895 Info, contrlr, FUNC_ID_ZW_ADD_NODE_TO_NETWORK:
2019-12-04 01:19:52.895 Info, contrlr, ADD_NODE_STATUS_LEARN_READY
2019-12-04 01:19:52.895 Detail, Node001,   Expected callbackId was received
2019-12-04 01:19:52.895 Detail, Node001,   Expected reply was received
2019-12-04 01:19:52.895 Detail, Node001,   Message transaction complete
2019-12-04 01:19:52.895 Detail,
2019-12-04 01:19:52.895 Detail, contrlr, Removing current message
2019-12-04 01:19:52.895 Detail, Notification: ControllerCommand - Waiting
2019-12-04 01:19:52.895 Info, WriteNextMsg Controller nothing to do

Bump. Any suggestions?

I solved my issue and hopefully, this post will help some else. Below is a recap.

From Phil Hawthorne all way at the bottom in the comments section.

Hi guys,
I’ve just done the configuration export in my Synology NAS, edited the file, added my Z-Wave Aeotec device to the file under the ‘devices’ section, imported the configuration back in the Docker GUI in Synology and it worked! The Z-Wave component was detected by HA in the Docker and initialized successfully.
No need to use the command line. We can still use the convenient Docker GUI in Synology this way!

You need to add the following piece of text in you config file exported from the GUI:
“devices” : [
“CgroupPermissions”: “rwm”,
“PathInContainer”: “/zwaveusbstick”,
“PathOnHost”: “/dev/ttyACM0”

This solved my issue using the UI to Add nodes. In my case, the Z-stick was always visible in the UI, but I could not Add any node.

This is great for those of us who are not command line friendly! :slight_smile: