Z-wave door sensor state never changes

Hello, I’m new to HA, hass_io and to z-wave. (Awesome community!)
I have hass_io running on a Pi3 with aeotec zstick gen5. I’ve managed to add my z-wave door sensor (Aeotec door/window 6) and I can see the open/close events in the OZW log. It looks like this…

Door open:

2017-08-05 09:49:51.393 Info, Node002, Received Basic set from node 2: level=255. Treating it as a Basic report.
2017-08-05 09:49:51.393 Detail, Node002, Refreshed Value: old value=0, new value=255, type=byte

Door close:

2017-08-05 09:49:54.796 Info, Node002, Received Basic set from node 2: level=0. Treating it as a Basic report.
2017-08-05 09:49:54.796 Detail, Node002, Refreshed Value: old value=255, new value=0, type=byte

Here’s the door sensor as it appears in the HA states tool.

node_id: 5
value_index: 0
value_instance: 1
old_entity_id: binary_sensor.aeotec_zw112_door_window_sensor_6_sensor_5_0
new_entity_id: binary_sensor.aeotec_zw112_door_window_sensor_6_sensor
friendly_name: Aeotec ZW112 Door Window Sensor 6 Sensor

The problem is the state in HA never changes. It is always “on”. I gathered from some other posts here that I should try changing the report type to “binary sensor”, usually done via ozwcp tool, but in the case of hass_io, through the Zwave manager page in HA. I tried that and it didn’t seem to change anything. I tried all possible values for report type, restarted HA after each change and I ensured the sensor was awake during the change by manually pressing it’s button for three seconds, which is supposed to keep it awake for 10 minutes.

Can anyone offer me a clue? Thanks, in advance!

I resolved this using ozcp via a docker container on my workstation. See: Aeotec door sensor 6

1 Like