Z-Wave dual module - appears as three devices & cannot set rooms?

Hi, I’m in the process of trying to migrate from Homeseer to Home Assistant.

I moved the zwave.me uzb stick to the home assistant machine, and all the devices have re-appeared.

However, the TKBHome dual switch modules I use for light control appear as THREE switches, and the location setting applies to the whole device?

Each module controls lights in two different rooms!

In Homeseer, they were configured as two devices in different locations, with the overall module (no switch shown) having it’s own location info but hidden.

How do I recreate that in Home Assistant?

You can change the entity’s area in the entity settings.

with the dual switch module, changing the area from either switch sets both switches to that area, rather than them being independent?

You said you have three switches, is that three switch entities?. Can’t you set the area individually per switch entity as seen in the screenshot?

in devices, the module shows as two switches; however selecting either and changing the area changes it for both switches.

In the dashboard, it shows as three switches, with the top one operating both the actual switches!

See below:

(I have a lot more devices connected than shown, I’m only adding some to the dashboard for testing, as I learn my way around the system).

When you click on an entity the first thing you want to do is toggle the “Use Device Area” button. Once this is off it will allow you to specify the device area for that specific entity. The reason the area keeps changing for both devices is because your probably have the area already setup and instead of clicking on the toggle you click on the underlined text that says change the device area.
brave_screenshot (2)

In the dashboard, the text that appears at the top of each card is called the Title. The switch that appears next to the title turns all devices in that card on and off regardless of the location or any other attributes they have.

Sorry, I’m not able to reproduce that. I was able to place two entities for the same device in different areas, following the steps (1-3) shown in my screenshot. As long as your dashboard is still the automatic one (you have not selected “take control” in the dashboard settings), it should update. You may need to refresh the page or re-navigate. Maybe you should provide a screenshot of the entity settings for confirmation.

I don’t see three switch entities in your screenshot. I see you have two switch entities each in two areas. There is an additional area toggle which would toggle all devices in an area.

That’s it - I was reading the earlier post as if the first thing was to turn that on.
It also removes the extra “global” switch, once the individual devices have separate locations…

Thank you!