Z-Wave dying after several hours - Serial port errored: The serial port closed unexpectedly!

I just rebuilt my HA box, using a NUC this time instead of a laptop. Z-wave (and Zigbee for that matter) is working fine, but after several hours, just dies. It is a HUSBZB-1 stick I’m getting this in the Zwave JS logs:

2024-02-03T18:24:12.195Z DRIVER Serial port errored: The serial port closed unexpectedly! (ZW0100)

Also getting this in the main log:

Logger: bellows.uart
Source: /usr/local/lib/python3.11/site-packages/bellows/uart.py:236
First occurred: 12:24:12 PM (1 occurrences)
Last logged: 12:24:12 PM

Lost serial connection: SerialException(‘device reports readiness to read but returned no data (device disconnected or multiple access on port?)’)

I feel like this might have started when I tied the alternal Z-Wave JS UI addon - then reverted back, but I can’t be sure. Any thoughts?

Maybe you are running into this bug?

I don’t think so. It works perfectly for several hours, then dies. Seems like a different issue.


In my case, it is the SkyConnect stick that stops working after a few hours and the problem can only be solved by unplugging it and plugging it in again. A downgrade to 11.1 solved the problem for me.

There’s also:

You’ll probably need to start looking at the host logs to see why your USB device is disconnecting.

You can also try disabling soft-reset in the Z-Wave add-ons in case that’s the issue, however you would see it immediately upon add-on startup.