Z-Wave fails after every reboot, and has done so for some time

I have only been using Home Assitant for well 9+18 months (two different homes, same hardware, Pi4 8GB and SSD over UDB3, plus Z-Wave from Zwave.me UZB (ZMEEUZB), and all the latest upgrades, oh and a Zigbee from HA :wink: - do note I run the original built in Z-Wave integration, no addon like Z-Wave.me own integration).

I think it always had a problem with reboot, no matter what or how I connect the parts to my Pi4.

Any reboot have more than 75% chans/risk of failing to start the Z-Wave integration.

Now I have read a lot of googleposts so to speak, and know that this seems to be a constant issue for some at least.

My simple question, after last nights power out which completely managed to fail Z-Wave restart when power was restored which makes me very sad, will this ever be resolved?

I have after all used the same UZB1 stick with for example Home Seer, which always worked without this hickups at close to every single reboot.

If the point of this post was to vent your frustrations, they you’ve achieved your goal. If however, your goal is to solve this problem that you’ve implied is widespread, you’ll have to dig in with a bit more effort. To answer your question, resolving this problem will require you take charge and not passively wait for a magic fix.

Start here How to help us help you - or How to ask a good question - Configuration - Home Assistant Community (home-assistant.io)

Provide some details about how your Z-wave integration is configured to use your Z-wave controller - what is the hardware path configured?

Did you confirm that path is still valid after the reboot? Many of these problems wind up as the hardware is not at the path or the hardware itself needs a hard reset.

Did you unplug the controller and reset it?

What are the errors in the Home Assistant log for the Z-wave integration failure?

Personally I run the Z-wave JS UI Add-on and not the core Z-wave integration. It provides its own UI and logs that make troubleshooting Z-wave easier. It’s the same software HomeSeer has decided to migrate to.

Frustrated I was a year ago.
Searching I have done more times than I can recall.
Tried to install Add-on, which failed, and yes I bailed out of that.

One can always argue what and why, how setup is and all. Still in the end of the day, I have done more than you can imagine. The only way to resolve this seems to start all over, since, well, that seems to be the general answeer to all this.

So, since this does not work I will have to figure out a stable solution - I will not ask for any more help.

You still seem frustrated. Why not start with the Z-wave integration errors in your log? Do you need help finding those?

My initial recommendation to you would be to buy a mini UPS to prevent your fragile setup from losing power, treating the symptom instead of the cause. But if that is too expensive, consider at least upgrading to a newer Z-wave USB dongle, as the UZB is getting old and has known issues. And if you do decide to start over from scratch, consider using the Z-wave JS UI add-on instead of the default so that it’s easier to verify settings and retrieve logs for the next time something doesn’t work.