Z-Wave graph (without the python)

You need to clear your browser cache.
Assuming you’re using Chrome - Ctrl+Shift+Delete shows the dialog where you can do exactly that.

That helped, thank you! Looks great!

i also updates the html file … cleared brwoser cache completely but no new result… still old pic

Amazing work! I just found this and had it installed in less than 5 minutes. Thanks for putting this together!

If you could try it in the Incognito Mode and:

  • you see the new stuff - that means something went wrong with the cache purging
  • you don’t see the new stuff - which means that something went wrong with the upgrade.

Thank you for the update! This is still my most useful Home Assistant add-on.

I just replaced the HTML file… that’s it right ? Still seeing old graphs

This is SO awesome now! Thank you :grin:

All my z-wave devices have friendly names already.

If I edit the name in the zwconfig will it mess anything up on my devices or will the name just change and everything else in my HA stay the same?

They should stay the same in HA as they are only taken from OZW config if you don’t specify them explicitly.

I’ve checked and I’m already taking the “friendly_name” attribute for the graph. Is it possible that you have provided the names for the sensor entities but not for the z-wave devices themselves?

All of my devices definitely have friendly names. I set them through the UI. Does that make a difference vs setting them in the config yaml?

Very nice, however I’m a z-wave lightweight and have only 4 devices. How can I disable the mini map for now? I have it in a lovelace iframe card and it overlays the main tree.

Updated to the latest file and cleared my cache (Chrome and Firefox), but nothing shows up, even after numerous refreshes and HASS restarts.


I installed from the code above. Everything seemed to go fine, no errors, but mine does not have the legend or other options I am seeing in other screenshots. What have I done wrong??

I think I was using old code. Found the link to the git and am trying that now.

Any ideas why mine looks like this? I’ve tried a few browsers and verified that I’m using the latest code.

I’ve seen this too with both Safari and Chrome. Refreshing the page seems to fix it.

Firefox too, a refresh does fix it.

Ahh ok a refresh of the whole page does seem to work. I kept just clicking back to my Overview page and then back to this one, thinking that would refresh it. Thanks

Same issue with Opera.